Highlighted
M.H.
Bronze

Dell XPS M1530 Display Problem.

I have almost 3 years old Dell XPS M1530 laptop that's been very reliable until couple of weeks ago when the display started to act weird. When I turned on the computer, the screen went blank not even DELL logo page. Windows started normally since I heard start-up sound but no display. When I restarted the computer, no Dell logo page, but Windows screen appeared with lowest brightness. Also, I could not adjust brightness with fn+arrow up key. When I restarted the computer third time, Dell logo appeared and the display functioned normally. This symptom lasted for about 3 days. I cleaned heat sink and made sure that the heat sink and video chip was in good contact as it was recommended by Dell forum. Everything seemed working fine since then but 3 days ago the problem started again. This time, no Dell logo but Windows screen appeared with lowest brightness and fn+arrow key did not work at all. However, if I restart the computer DELL logo appears and everything is fine. The problem occurs only when I start the computer after completely turn off the computer. When I restart the computer everything works normally. Does anybody have same or similar problem as I do and if you do, do you have any idea what might be the problem? My concern is that if I keep using the laptop this way, things might get worse and end up replacing motherboard or entire display. Thanks for your reply in advance and hope any of you may have some ideas as to how to address this problem. My laptop's specs are following:

Dell XPS M1530

T9300@2.50GHz

4.GB Ram

NVIDIA GeForce 8600M GT

Windows Vista 32

0 Kudos
18 Replies
KirkD
Diamond

Re: Dell XPS M1530 Display Problem.

Sounds like it is NOT a hardware problem, probably something related to the cold boot.You should, however, download a temperature measuring utility to check the CPU/GPU temps to confirm that the heat sink was properly installed. Try HW Monitor.

Are you Vista or Win 7?

First, try installing the latest video driver from Nvidia, NOT from Dell. Install the new driver without deleting the old driver.

If no go, next run sfc /scannow to check for corrupt system files.

Next, do a repair install.

Next, backup all your data, favorites, phone books, etc., and Reinstall Windows from the Recovery Partition.

XPS M1530, Win 10 CU Pro 32-bit
Inspiron E1705, Win 10 CU Pro 32-bit
Dimension 9100, Win 10 AU Pro 32 bit
Inspiron 660, Win 10 CU 64 bit
Inspiron 3668, Win 10 CU 64 bit
Asus T100 Tablet, Windows 10 CU 32 bit

0 Kudos
KirkD
Diamond

Re: Dell XPS M1530 Display Problem.

Sorry, missed the last line where you listed Vista,

XPS M1530, Win 10 CU Pro 32-bit
Inspiron E1705, Win 10 CU Pro 32-bit
Dimension 9100, Win 10 AU Pro 32 bit
Inspiron 660, Win 10 CU 64 bit
Inspiron 3668, Win 10 CU 64 bit
Asus T100 Tablet, Windows 10 CU 32 bit

0 Kudos
M.H.
Bronze

Re: Dell XPS M1530 Display Problem.

Thanks for your reply KirkD.

The problem is that the first DELL logo screen where you can select either diagnostic or setup page or boot option does not appear if I cold boot and fn+arrow key does not work. When I restart from windows though, things work with no glitch. I do use CPUID HWMonitor all time since the problem first occurred but nothing really seems odd regarding the temperature, voltage, fan speed and etc. I am 100% sure software is not an issue because I just recovered entire system using Dell recovery partition. I just spoke with a friend of mine and he suggested that the BIOS bootstrap might be corrupted due to some reason and to upgrade BIOS. Since I am using BIOS ver. A12, which is the latest, I might upload old BIOS and then upgrade to A12 ver. I will post result of BIOS upgrade. In the mean time, could this be related to the video chip? I read that Dell sued NVidia for their 8400/8600 laptop video chip set. I hop it is not since that means motherboard replacement. xD

0 Kudos
KirkD
Diamond

Re: Dell XPS M1530 Display Problem.

This doesn't fit with the Nvidia GPU problem. There, the chip was manufactured incorrectly, and the actual structure would fail because of wide temperature cycling. Wide temp variations caused the problems; the chip did not cause the temperature variations, but operations such as temp spiking during demanding usage (games, etc.). A BIOS update (A12) which ran the fan more at lower speeds during normal operations seemed to help.

The failures are always corruption of the screen display because of the failing GPU. In order to benefit from the suit, you must be able to show corruption.

Reinstalling the BIOS is certainly worth a try.

XPS M1530, Win 10 CU Pro 32-bit
Inspiron E1705, Win 10 CU Pro 32-bit
Dimension 9100, Win 10 AU Pro 32 bit
Inspiron 660, Win 10 CU 64 bit
Inspiron 3668, Win 10 CU 64 bit
Asus T100 Tablet, Windows 10 CU 32 bit

0 Kudos
M.H.
Bronze

Re: Dell XPS M1530 Display Problem.

I updated BIOS today but the problem persists. What puzzles me is that the symptom only shows when I cold boot the computer. Soft boot, no problem. I am going to try and see if there is loose cables or connectors although I don't think that was what caused the problem. I guess the worse scenario is to replace the motherboard entirely, which will cost me ~ $250.

0 Kudos
M.H.
Bronze

Re: Dell XPS M1530 Display Problem.

I finally had chance to open up the keyboard area and inspect the display related cables and connectors. No connectors were loose or no cables were damaged. Anyway, I reseated all display related connectors and reorganized cables just to make sure that the problem is not caused by loose or damaged cable. And when I booted up the first time, display worked normally. Now, I've been using my laptop without the display problem for 3 days now. It seems like reseating and reorganizing the cables fixed the problem. I hope this is a permanent fix as I am planning to use this laptop for a long time. If you anyone of you have similar problem, you might try what I tried. It may fix your problem as well.

0 Kudos
Nera23
Copper

Re: Dell XPS M1530 Display Problem.

How did you open up the keyboard? I left my laptop on for a bit earlier and thought it just went to sleep, but when I tried to start it up the screen would not turn on at all. It remains black still, no Dell logo or anyting on it for that mater, however it sounds like it's powered on. The webcam light didn't come on either. After the inital turning on, all the blue lights flickered for a sec and I can hear the sound of cd starting up loud then it goes quiet, but is still on. I have a DVD in the cd drive and am unable to pop it out. I tried Fn+power and have the 3 lights to the right of the home button (I think they are num and caps lock) on with the first one on the left blinking continuously - no idea what that code is tho. My xps m1530 is almost 3 years old and I've had other issues, but nothing like this. Also, if I try to plug in an external mouse that diplays the red light when plugged in, it only works for a split second while I'm plugging it in. I fiddled with it a bit and was able to plug it in half way so it actually stayed on, but that doesn't help anything, just thought I'd mention it anyway. I read other forums where it was suggested that it may be NVIDIA or a faulty chip of a sort, but I have no idea what that really means, not too computer savvy if you know what I mean Smiley Sad.Can anyone help with this?

0 Kudos
M.H.
Bronze

Re: Dell XPS M1530 Display Problem.

In order to disassemble your laptop, you need to follow instructions below.

http://support.dell.com/support/edocs/systems/xpsM1530/en/SM/index.htm

This is a dell provided service manual for M1530.

I read somewhere that if you have one of the 3 blue lights blinking when the computer is fn+powered, that means there is some serious error with your system. However, I do not remember which blinking light indicates what error. Did you hear any beeping when you turn on your computer? That could also be a clue to find out the problem. It is kind of weird that you cannot eject the DVD using the eject button because once your DVD drive is powered up, you should be able to use eject button to pop out the DVD.
What I would try first is to reseat or try working RAM on your computer since invalid ram causes unbootable system or system halt and your description fits (no dell logo, mouse working for only split second and etc.). Video chip may have been damaged like others suggested, which also could cause system halt. If it is your Video chip, you need a new motherboard. In my case, after trying everything and actually the computer worked fine for several days since last repair-try, I concluded that the NVIDIA 8600 GM video chip got overheated and the ball soldering got damaged. There are some ways to repair this but replacing motherboard probably is the most reliable way. My guess is that your are going to need a new motherboard if you want to keep your system or a new laptop.

0 Kudos
MJYUMPING
Bronze

Re: Dell XPS M1530 Display Problem.

Hi M.H, does it still working by now with no problems?

I also have a problem like you had. I've tried reseating the display cable. Oh, here are my reports:

*The screen works when I connect it to external monitor via VGA Out. But it doesn't work with HDMI, I don't know why is that so?

*D + Power (screen diagnose) when I do it on swith on, the screen lights up.

0 Kudos