Inspiron 1440 over sensitive touchpad

My Inspiron 1440 laptop running on Windows 7; I have always had the problem with the cursor jumping all over the place and sometimes it just deleted the whole of document by itself.  So frustrated to use.  I just found that it's a known problem as it happens to many of the other models.  Does anyone have a solution to fix it?  What does Dell Support have to say about this?  It takes me forever to type this message as it keeps jumping around wherever the mouse pointer is.  Any feedback is appreciated!



0 Kudos
4 Replies

Re: Inspiron 1440 over sensitive touchpad

Welcome to Dell Community

I apologize for the inconvenience this has caused you.

Please follow the below steps.

1. Try enabling touchpad button on the keyboard.

2. Upgrade the latest touchpad drivers from support http://tinyurl.com/2xqyr

3. Change the sensitivity settings for the pointing device from control panel –mouse –device settings –Dell touchpad

New systems have added gesture features to the touchpad hardware and the drivers. A few of these features are two or three figure scrolling ,pinch zoom ,circle zoom ,rotate and swiping  These new features may  be the reason for the erratic cursor movement since most are turned  on by default .

You can disable or modify the way the feature works in the touchpad drivers properties



Dell | Social Media Outreach | Global Social Media & Community

0 Kudos

RE: Inspiron 1440 over sensitive touchpad

When I click on that link, it takes me to the dell page, but how do I find the driver to download?  I've been having this same problem for the last couple years.  Cursor skips around while I type, and then see I'm in a whole different place, inserting text in a previous paragraph, or somewhere.  I'd like to try to change the sensibility of the touchpad, but don't know what to try this before I go out an buy a separate keyboard., or new computer.


Ron McNeal

0 Kudos

RE: Inspiron 1440 over sensitive touchpad

Hi Ron McNeal,

Please enter your service tag # on the link below and click on ‘Get drivers and downloads’ then download the touchpad driver from ‘Mouse, Keyboard & Input Devices’ section onto the system and install it.


Also, I would advise you to download and install the ‘TouchFreeze’ software from the link below and check for issue resolution.


Please let me know if this helps.

0 Kudos

RE: Inspiron 1440 over sensitive touchpad

Hi there!

I've been experiencing the same problem with my Latitude 3540 (Late 2013). Very irritating indeed! I came to Dell forum looking for advice and found this thread.  I've just installed  the software following your recommendations. I'm now typing this comment and it looks like it works fine! Smiley Happy My coursor has stopped jumping like mad and my touchpad doesn't react to every slightest touch anymore.

Why this problem is happening with new DELL laptops? I was using an HP laptop for 10 years before buying this Dell and there was no such a problem!

0 Kudos