Inspiron 1720 Battery isn't recognized by Windows

I just inherited my Son's Dell Inspiron 1720. He recently did a complete install of Windows XP Pro, replacing the factory installed Vista. Ever since installing XP the computer has been acting very strange. It was taking forever to boot up, which seems to have gotten a little better after installing all Windows updates.

The major problem however is that the system doesn't recognize the battery at all. It doesn't exist according to both the BIOS and Windows. There is no color to the battery indicator. If I unplug the unit it immediately loses power. I even bought a new battery which didn't help. The computer stays powered up as long as it's plugged in. I also get a black screen during POST indicating that an improper power adapter is connected and I must hit F1 to boot to Windows. The power adapter is the original one that came with the unit. I even tried another Dell adapter that a friend has and I still get the same results.

I'd appreciate it if anyone could help me with this strange problem. I read somewhere that I should install Dell Quickset but I can't find one that is compatible with XP.

0 Kudos