Highlighted

Latitude E6400 - Not creating docked hardware profile

We got a bunch of new Latitude E6400 (Windows XP Pro SP2) laptops in with port replicators. I've pulled one out for testing and I'm noticing that when we boot it in docked mode, it will not generate a "docked" hardware profile. We've rebuilt our test E6400 with our custom Dell Image Direct restore DVD, but it still won't generate a docked hardware profile, so there is no "undock" option available from the Start menu.. Anyone experience something similar? Our D620 and D630 models never had an issue like this with their specific port replicators. Am I missing something obvious?

 

 

Thanks!

0 Kudos
34 Replies
Clifton74
Copper

Re: Latitude E6400 - Not creating docked hardware profile

I'm also experiencing this with the new E6400 & E6500 latptops in Vista.  I haven't verifed the problem with Xp yet.   I would like to see an solution for this problem as well.  Can someone help?  Thanks
0 Kudos

Re: Latitude E6400 - Not creating docked hardware profile

Okay, I noticed this problems about two weeks ago when we got our first batch of Latitude E6400 laptops in. I originally thought it was a problem with our OS build image and contacted Dell Support to find out if this was unusual. Dell Support did think it was unusual, but could not rule out that my build image was causing the problem.

 

I went back and created a new build image through Dell Image Direct and still had the same issue as described in my opening post. I was at a total loss and called up Dell Support once more this afternoon. After speaking with a Dell tech, I was told that there is no longer a docked/undocked profile with the "E" class of Latitudes and you do not need to hit "undock" in Windows to remove your laptop from the port replicator. He pointed out that Dell even removed the "undock" button from the new port replicators.

 

So, according to Dell Support, there is no more docked/undocked hardware profiles with these laptops and you can remove them from the port replicator by just pressing down on the eject button.

 

I don't have a problem with this, but I wish the first support tech I talked with had explained it to me. Now I just need to wait for Dell to update their control point software so I can set up a software profile that will disable wireless when the laptop is on the port replicator.

0 Kudos
rejohnson76
Bronze

Re: Latitude E6400 - Not creating docked hardware profile

What a pain - not using the built-in Windows docking profiles, but requiring ControlPoint is a major step BACKWARD, IMHO.  Why should customers depend on this software, especially when it's not even ready?  We, too, want to turn off wireless when docked, and this will delay our laptop deployment as we don't want to touch them again when Dell finally gets CP updated to include wireless (not like wireless is a new technology???).

0 Kudos
danthegrey
Bronze

Re: Latitude E6400 - Not creating docked hardware profile

Same issue, e6400's and m4400's.  I don't think it hot undocks properly either. We've had all kinds of issues with the laptop screen not coming back on after ejecting.  I too am annoyed that we have no good way to disable wireless while on a dock.
0 Kudos

Re: Latitude E6400 - Not creating docked hardware profile

To sort this all out:

 

The E-series does not use nor does it NEED dock profiles. The dock is considered known add on hardware. Hot dock with Device Manager open and expand the USB heading. Adds two when you dock, removes them when you undock. 

 

Using dual spanned desktop? Hotdock, second monitor goes off, redock, there it is, laid out the same.

 

It is a world of improvement and has NOTHING TO DO WITH the DCP. It's from items added with the Notebook System Software and Chipset software after OS load.

0 Kudos
rejohnson76
Bronze

Re: Latitude E6400 - Not creating docked hardware profile

Yes, but it's handy to be able to enable/disable hardware under docked/undocked profiles - especially the wireless NIC.  This feature is built in to Windows, but Dell chose to bypass it without a full solution - we're still waiting for the wireless module in DCP to be able to disable the NIC when Ethernet is connected.

 

I did find that the E-series with Intel 5300 AGN is part of the problem because it doesn't have the property to Disable When Wired Connect, which the Dell 1510 N card does.  I'll probably order my next E6400s with the Dell card now.

0 Kudos
uslacker
Bronze

Re: Latitude E6400 - Not creating docked hardware profile

To sort this all out:

...

Using dual spanned desktop? Hotdock, second monitor goes off, redock, there it is, laid out the same.

 It is a world of improvement and has NOTHING TO DO WITH the DCP. It's from items added with the Notebook System Software and Chipset software after OS load.

 

The problem we see is that if you undock with spanning desktop, anything that was opened on the lost moniitor now opens off screen.  previously XP would realign everything on the remaining desktop.  Anyway to make this happen?  One of our execs is frustrated...

 

\\uSlacker

Tags (1)
0 Kudos

Re: Latitude E6400 - Not creating docked hardware profile

We are seeing issues with the E6400 and E6500 with port replicators.  The replicators do not present an undock button and there is no “undock” option on the Start menu with XP svc pack 3 on these machines.  According to this Dell forum, you should be able to just press eject on the replicator.  I’m not sure it hot-undocks/ejects properly. I have users where the laptop screen not coming back on after ejecting and they are forced to do a hard shut down, sometimes multiple times to get it to come back. 

Re: Latitude E6400 - Not creating docked hardware profile

Dell is saying that the bios versions on these machines are already out-dated.  Ours have version A06 and the Dell site now has version A11.  I will try that on one of the machines and let you know how I make out.

0 Kudos