Highlighted
Majicmike
Copper

Latitude Keyboard Non-Working 8 i k Keys Possible Fix

I've waited to post this for three months to make sure that this is a viable solution for the 8 i k keys not working, rather than a temporary fix like reseating the keyboard connector, or twisting the machine.  It has been three months and my keyboard is still working great.  This fix is essentially cleaning the keyboard connector contacts which has been mentioned on this forum a time or two. I noticed that the contacts on the black connector were a little dark and may have some oxidation on them.  Contacts of such a small size may suffer from even the slightest amount of oxidation.  Also, these contacts are typically nickel or tin coated, which will both suffer from oxidation over time, in either case they should have a bright silver appearance.  Mine were not shiny at all, but a dull grayish silver.

What I did is as follows: I removed the keyboard as I've done many time before due to this problem.  I found the smallest pencil eraser I could find, in this case a mechanical pencil with an eraser about 1/8th of an inch in diameter.  I trimmed it down even smaller to get in around the contacts of the black connector.  As I rubbed the eraser on the contacts, the contact regained the shiny silver appearance that they should have.  I used a can of compressed air to clean off all the eraser rubbings.  I cleaned both the keyboard side connector and the motherboard side, and made sure not to leave any eraser shavings in either. The motherboard side was vey difficult to clean due to the small amount of clearance between the contacts and the connector walls.  Be sure not to leave any leftover shavings, as they could impede or prevent electrical contact and make things even worse.  Anyhow, after closely inspecting for eraser shavings, I replaced the keyboard, and tested it out.  All my problem keys were once again working, including the page up/down keys.  They have now been working for the past three months steadily.  I just wanted to share that this was a successfull solution for me.  I hope it helps, some of you with the same issues.  Also, thanks to those on the forum who mentioned this in the past.

--Majicmike

Dell Latitude CpxJ 650

 

 

0 Kudos
66 Replies
dbuk
Silver

Re: Latitude Keyboard Non-Working 8 i k Keys Possible Fix

I've had similar problems - now on my 3rd CPxJ keyboard in 2 years, all replaced under warranty.  Reseating should have adequate cleaning effect due to wiping the contacts in the connector.

However, the last service engineer hinted that the cause is identified as dissimilar metals in the contact faces causing electrolytic corrosion in a moist atmosphere.  He also suggested a modified keyboard connector is now being used with an oil impregnated plug shell - although the technically correct solution would be to use compatible contact metals.

For users with CPx models afflicted the best solution is to make sure any flaky keyboards get changed just before warranty ends  

 

0 Kudos
Koomie
Copper

Re: Latitude Keyboard Non-Working 8 i k Keys Possible Fix

Thanks for the solution majicmike.

As a network manager I've suffered this with about 200 machines (out of total purchase of 450).

After reading the many different fixes that have been posted here, this seems to me the most believable fault diagnosis / solution.

I really think Dell should have provided a free fix for this - It is obviously a design fault.

It's a shame they have let themselves down so badly on this issue.

I cannot afford to risk going with them for future hardware prchases.

 

 

 

0 Kudos
N5SK
Copper

Latitude Keyboard problems

It's obvious from reading these postings that Dell has a problem with their keyboards that they haven't adequately addressed.  I'm still trying to decide whether to purchase two Dell Latitude D800 laptop computers in the hope that Dell will soon solve their keyboard problems.  Is there anyone nearby me (ZIP Code 22182 in the Northern Virginia area) who has a D800 that I could look at?  I'd like to look at the keyboard and type on it to see if it's really as bad as everyone says.  Please reply directly to me at  kartys@ncs.gov  Thanks. 
0 Kudos
christi2
Copper

Re: Latitude Keyboard problems

I would like to know why it is always the 8ik column of keys that stop working.

There are 25pins on that connector, and it is one particular pin (From memory 24) that does that column.

Why does that one always fail, and not one of the others?
0 Kudos
christi2
Copper

Re: Latitude Keyboard problems

I think that I have just figured out the root cause of this problem. I just took my CPx apart again to try an erasor on the connectors.

When I put it back together the 8ik, keys didn't work at all, straight away.

What I found was that if a push the connector gently to the left (towards the hard disk) then the keys work. If I push the connector to the right (towards the media bay) then the keys don't work.

Basically the screwing the keyboard down squashes the keyboard ribbon cable and makes it push that connector to the right.

I guess that oxidisation may play a part too.

Probably the ribbon cable applies enough force to the right that only a tiny bit of contact pressure is left on the pin that does 8ik,

I having yet found a reliable solution yet, but probably a carved bit of wood stuck between the connector and the media bay could hold it standing upright as the keyboard is screwed down.
0 Kudos
cates2
Silver

Re: Latitude Keyboard Non-Working 8 i k Keys Possible Fix

I have a problem with the Shift and Control Keys - it takes several tries to get them to work. Is is the same issue?

1) how do i remove the key pad "cover" to reseat it withour breaking it?

2) how do i remove the entire keyboard?

thanks -cate

 

0 Kudos
kculp
Bronze

Re: Latitude Keyboard Non-Working 8 i k Keys Possible Fix

It is possible that some of the above solutions work, but the root cause is a short between the keys 8,i,k against the metal housing that lies underneath the right side of the keyboard. If you take the keyboard off, you do not need to undo the ribbon connecting the keyboard (although I would try cleaning the connectors AFTER this if we don't fix it this way). OK, here is what needs to be done. It is simple.

1) take out the screws labeled "k" on the underside of the notebook. this, btw, stands for keyboard screw

2) Get a wide rubber band. Cut it about it about 2 inches in length (trim it later to fit).

3) Place the rubber band over the metal ridge on the housing in the approximate location of the 8 i k keys.

4) Secure in place with a piece of scotch tape (I taped mine along the edge of the plastic housing to the far left, but careful as it is not heat resistant and don't put tape directly on the metal- is there a heat reisitant glue??). Alternatively, if there is a way to keep the rubber band there without tape or glue, do it. I found it flimsy though and wondered if it would misplace in subsequent intrusions into the machine. BTW, that little "ridge" is about 1/4 wide and runs the length of the metal housing on the LEFT side.

5) Reassemble the keyboard and tighten the screws.

OPINION. I think this is a design flaw with Dell Lattitude, but I don't know. I took my machine under warranty and the keyboard was replaced. It worked fine for about 3 months (of course out of warranty by that time). There is most likely a short between these keys and the housing. Easily fixed. Moving the cable around etc and cleaning the pins may be OK, but I don't think that is a long-term solution. This one is.

0 Kudos
shooter100
Copper

Re: Latitude Keyboard Non-Working 8 i k Keys Possible Fix

This is still going on???

Check out this page for how I fixed my Dell Laptop 8ik, keyboard problem:

http://www.geocities.com/shooter100k/index.htm

I didn't do any of the questionable Flipping this, Tightening that, and Cleaning the other stuff... take a look. 

 

shooter

 

Message Edited by shooter100 on 08-28-2003 07:02 PM

0 Kudos
cates2
Silver

Re: Latitude Keyboard Non-Working 8 i k Keys Possible Fix

Am I the only one that is having this problem with the Shift and Control keys on the left side?

Is my problem something different?
0 Kudos