Power Adapter Not Recognized

I bought a Dell Studio 17xx back in March. Subsequently, I deployed to Afghanistan. Two months ago, when I turned on my laptop and plugged in the adapter, i got a "Power Aapter is not recognized, please plug in a Dell 90W power adapter. The computer will be powered but will not charge the battery"...or words to that effect. Since it is under warrenty, i e-mailed Dell tech support, and after following their troubleshooting guide, it was determined that I needed to replace the adapter. I recieved the new adapter, which did not correct the issue. Tech Support then mailed me a refurbished systemboard, power card, and sound card. I swapped out the parts, and the issue went away...for about two days or so. It then returned. Tech Support mailed me out another systemboard, power card, sound card, power adapter, and battery. I swapped out all the parts and got a "Windows would not start" message, which nothing would fix. So, I swapped back in the 1st replacement systemboard, and kept in the 2nd replacement power card, sound card, battery, and adapter. Again, everything worked fine for about a week. When I plugged the laptop back in last night, I found that the error had returned. I tried plugging in a different Dell adapter, just in case, and that did not solve the issue. I have tried moving the cord to different outlets, which makes no difference. I have the laptop plugged into a PowerSquid surge protector, in which I have a desk lamp, cell phone charger, and USB charger for my Zune plugged in, and they all charge with no issues, so I doubt that it is the power coming in from the wall or the Squid. Could it be something in the laptop chassis itself causing the systemboard or power card to ground or short out? I really do not want to have to mail my system in to Dell for them to fix as it is my only source of entertainment while on deployment...however, after only six months I shoul not be having issues such as this with a mostly new laptop. The BIOS is also up to date, as well.

Tags (1)
0 Kudos
1 Reply

RE: Power Adapter Not Recognized

This could be caused by your battery.  Your battery may be charging, but not at the rate expected.  Does your battery hold it's charge as long is it did 6 months ago, does it take a little longer to achieve full charge on you battery, does your battery ever receive 100% charge?  I can also be caused by a minor glitch in your BIOS/battery/charger interaction.  I would check the battery function first.  Most batteries today are made off-shore to "cut costs", and the cost cutting doesn't necessarily stop there.  Batteries are warranted for 3 years, "not to die".  That warrantee does not cover charge rate unless the battery becomes nonfunctional.

0 Kudos