Highlighted
hgunn
Silver

Run CPU at full speed?

How can I either bypass or disable the power saver feature in my Inspiron 8200's cpu? Its a 1.8 ghz P4 that never runs faster than 1.2 ghz, the default idling speed. I rarely run this computer on battery power and want it to run at full capacity.

I've tried all the Control Panel power options and have disabled the feature from the bios. None of these attempts have affected the cpu speed. Is there another setting somewhere?

Thanks..
0 Kudos
14 Replies
leo_wills
Bronze

Re: Run CPU at full speed?

Goto System setup(BIOS) by pressing F2 when you get to the dell logo screen.

In the BIOS goto the "Power Management" Screen it should be the 6 th page.

There Change the Intel Speedstep option to disabled.

This will stop the Energy saving feature on the laptop.

 

 

0 Kudos
hgunn
Silver

Re: Run CPU at full speed?

I went into the bios and disabled Energy Saving in the AC setting before I came here for help, leo. I'm sure I saved the change properly. I really thought that would do it, but my cpu speed is still only 1.2 ghz.

I'll disable the battery setting to see if that makes any difference.

Is there anything else I can try?
0 Kudos
spiked_martini
Platinum

Re: Run CPU at full speed?

Run a forum search on "speedstep". It will tell you everything you need to know.
0 Kudos
bacillus
Diamond

Re: Run CPU at full speed?

tried setting the power scheme to always on or desktop in control panel>power options?
0 Kudos
HMKrieps
Gold

Re: Run CPU at full speed?

Tried SpeedswitchXP? www.diefer.de
0 Kudos
hgunn
Silver

Re: Run CPU at full speed?

Thanks to all of you for the suggestions..The power option is set to 'always on'.

I've installed SpeedSwitch, but I haven't had any success in getting it to speed this bugger up. SpeedSwitch identifies only my idle speed, 1200 mhz, as the maximum speed, when its actually 1800 mhz. I've tried it with different energy saver settings; enabled and disabled in the bios. When energy saving is enabled, AIDA identifies the cpu correctly, its idle speed, maximum speed and current speed of 1200 mhz. When I disable it, AIDA merely identifies the cpu as a P4 that runs at 1200 mhz.

Does this mean I have a faulty chip, or am I missing something?
0 Kudos
schmieg
Gold

Re: Run CPU at full speed?

If you are running on battery, that is normal. If on AC, you should be able to set it to the maximum and it should read that. If you have disabled Speedstep in the BIOS, you will be stuck on the low speed.
0 Kudos
hgunn
Silver

Re: Run CPU at full speed?

I'm doing all of this while on AC power. Nothing I've tried has accelerated the cpu speed beyond its 'energy saver' idle rate of 1200 mhz, even briefly.

According to what I've read, there should be two different ways to force this cpu to run at 1800 mhz, its maximum rate.

One way involves SpeedSwitch, the software utility, and the other way is implemented with bios settings. I've tried them both, and have also tried combinations of bios settings with SpeedSwitch installed and running.

With Speedstep fully enabled in the bios, SpeedSwitch should identify and force the cpu to its maximum speed, but it can't find a capacity for any speed over 1200 mhz. According to the explanations inside the bios, I should be able to 'lock' the cpu speed to its highest rated level by disabling Speedstep, but disabling it has no effect.
0 Kudos
schmieg
Gold

Re: Run CPU at full speed?

How about your power supply? Could you by chance be using one of the 70 watters instead of the 90 watt? That could cause these symptoms.
0 Kudos