Highlighted
bomber1978
Silver

XPS L502x - Realtek HD Audio no speaker or headphone sound

Hello,

I have an XPS L502x, I did a Factory re-insall from 3X DVD's after I changed from HDD to SSD ('m not sure if that has anything to do with the problem because I can't remember if it worked before I did the HDD to SSD swap and Factory re-install, however I do know it has worked at some time but it was possibly when I had done a manual windows and drivers install....

The problem is plugging in headphones or external speakers does not work, there is no audio....

Going to Control Panel - Hardware and Sound - Sound - Manage Audio Devices the SPEAKERS have a green tick, but REALTEK DIGITAL OUTPUT says "not plugged in".

Also when I go into Control Panel - Hardware and Sound - and click Realtek HD Audio Manager it simply does not open......

Any help appreciated, thank-you.

0 Kudos
27 Replies
Jim Coates
Diamond

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Going to Control Panel - Hardware and Sound - Sound - Manage Audio Devices the SPEAKERS have a green tick, but REALTEK DIGITAL OUTPUT says "not plugged in".

That is normal. You want the Speakers to be the default device.  Digital output "not plugged in" means that there is nothing connected to a digital output port which is okay because the headphone jack is an analog port.

Try looking into the "Configuration" and the "Properties" settings for the speakers, and if all settings look okay then try reinstalling the Realtek driver. If that doesn't help then I would suspect a hardware failure.

Jim Coates -- 14 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Hi,

I think this screenshot will tell you all you need to know, seems to me all is OK with it?

http://i43.tinypic.com/8wbf5g.jpg

The audio is coming from my laptop speakers, even though I have headphones in the headphone jack....

There is only 1 audio driver on the Dell drivers page for XPS 15 (I have L502x) which is linked below, and yes I have downloaded it :

www.dell.com/.../DriverFileFormats

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Bye the way, when I plug in / unplug the headphones in the jack I can hear a little static crackle, I'm not sure if that indicates there is no hardware failure?

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

I forgot to post this when I posted that last screenshot...

Below when I click on Realtek HD Audio Manager nothing happens at all... Nothing even opens...

http://i41.tinypic.com/ff1wee.jpg

0 Kudos
Jim Coates
Diamond

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

There is only 1 audio driver on the Dell drivers page for XPS 15 (I have L502x) which is linked below, and yes I have downloaded it :

I suggested that you re-install the driver because logically the problem is either in the configuration, the driver, or the hardware. By re-installing the driver you re-set the configuration to default, which would be that the speakers cut off when a plug is in the jack, and also would correct if the driver was somehow corrupted.

Jim Coates -- 14 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Strange, I went to Control Panels - Programmes - Uninstall and uninstalled Realtek HD Audio, when my laptop restarted the Windows jingle came through my headphones !!!!! Then I played a music file and it worked with headphones !!! Why is this working now that Realtek HD Audio is uninstalled ? ? ? 

So what do I do? Do I just leave Realtek uninstalled ? 

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Seems the Realtek folder is still in "Programme Files" but the one that was in "Programme Files x86" is gone....

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Re-installed and seems to be working now whenever I plug in or unplug headphones, but I got a rundlllll32 error....

However I still have the problem of when I click on Realtek HD Audio nothing happens, it won't open up eg:

http://i41.tinypic.com/ff1wee.jpg

0 Kudos
bomber1978
Silver

Re: XPS L502x - Realtek HD Audio no speaker or headphone sound

Agh now that I unplugged the headphones when I plug them back in they're not working again.......

0 Kudos