dell xps m1330 unable to shut down (and restart) with ubuntu 12.04 and Nvidia graphic card

I recently installed the ubuntu version 12.04 LTS and I noticed that, since then, my laptop (dell xps m1330) does't shut down completely. 

The fan continues to run and there is the blue light of the power signal still turned on. To really shut down the laptop I have to press for few seconds the power button and force the shut down. Of course I do not like this procedure. Because the laptop never shuts down, also the restart doesn't work.

I never had this problem with the previous versions of ubuntu and I have been using it for 5 years, so I tried many of them. 

I looked for a solution for this problem reading many forums with answers and questions from people who had similar problems. The only solution that worked for a little bit was to modify the grub file in /etc/default and add the option acpi=force to the GRUB_CMDLINE_LINUX_DEFAULT. I am saying the it worked a little bit because for few (2-3) times the laptop was able to shut down and restart, but then it failed again. 

Some people suggest that the problem is related with the Nvidia card, so I am leaving some information of my system hoping that can be helpful.

Nvidia driver version : 295.49

Graphic processor : GeForce 8400M GS

Memory: 256 MB

If you know how to solve this issue I would really appreciate your help.

Thank you


Tags (2)
0 Kudos