sleep mode in docking station

I have a latitude D 600 & a D Port docking station. I can not get this system to go into sleep mode when I press the electronic release button on the docking station. I have tried 2 other D 600 on this station, and when you press the electronically undock button, their systems go into sleep mode and then you can physically remove them from the station.  I have tried this system on other docking stations within my office and I get the same results.
I have flash by BIOS, updated the docking station drivers, updated the notebook software,  created new docked and undocked profiles, updated a ran the anti-virus, updated and ran the spyware program(s), cleared the start up menu in msconfig, did a 32 bit diags on the system - everything seems to check out fine. The system will go into sleep mode normally, as it is set to do, just not out of the docking station. Every time I remove the system from the station, I must do a hard boot and restart the system. 
Anybody have any ideas?
0 Kudos