Highlighted
yusrij
Copper

ImageAssist and custom OU

In my office environment, we got many OU for specific department and company for computer object.

i am very excited after found that imageassist can join domain and name the pc automatically.

I need to know, can imageassist customise for different OU in single image by prompt a selection of OU?

0 Kudos
6 Replies

RE: ImageAssist and custom OU

Hi YUSRIJ -  We have a detailed doc describing the process you can use for this,

if you wish to email our  mailbox  EMEA_OSImaging@Dell.com

 we can send you the documentation,

Thank you.

Dell Image Assist Support


 

 

 

0 Kudos
yusrij
Copper

RE: ImageAssist and custom OU

Hi

I have sent you an email few hours ago using my company's email.

Maybe you could also send the documentation to my personal email yusrijamal(a)gmail.com

Thank you.

0 Kudos
Delboy
Bronze

RE: ImageAssist and custom OU

would it be possible for me to get this info?

0 Kudos

RE: ImageAssist and custom OU

Hi Delboy,

Can you please email either of the below based on your location and we will send you the documentation,

US_OSImaging@Dell.com

EMEA_OSImaging@Dell.com

Thank you.

Dell Image Assist Support


 

 

 

0 Kudos
Delboy
Bronze

RE: ImageAssist and custom OU

Hi yusrij,

I was able to obtain the source files for the OSD customizer, but I have not been successful at getting the machine to domain join (exit code 1212 (The format of the specified domain name is invalid.).

I was wondering if you were able to get it working in your environment, and if so, would you be willing to share your OSDSettings.ini file with me (redacted as needed, of course)?

TIA,
Paul

0 Kudos
Delboy
Bronze

RE: ImageAssist and custom OU

on a hunch, I re-ran the DIA wizard and chose the option to not join a domain (leaving it at workgroup) and auto-generate the computer name, thinking that maybe the settings in the resulting unattend.xml file were not being replaced by the variables generated by the OSDSettings.ini file. After testing 4 different OU's, I found the everything is now working. Here is the format I used in my OSDSettings.ini file (I'm providing two examples to show how to structure the setting).

Hopefully this will save someone else some head scratching. Smiley Happy

;============================================================================================================
;Put your Location list here --- if install apps (for DIA only) per location you have to set first in [Applications] section AppsInstall=YES and AppsPerLocation=YES and AutologonSetInUnattendXML=YES
[Location]
List=Airport;Call Centers

;Detail per location

[Airport]
UserLocale=en-US
SystemLocale=en-US
InputLocale=en-US
Country=244
TimeZone=Pacific Standard Time
UILanguage=en-US
Prefix=AIR-
Suffix=
Domain=fqdn.domain.com
OU1=OU=Airport,OU=Workstations,DC=fqdn,DC=domain,DC=com
OU2=OU=Wireless,OU=Airport,OU=Workstations,DC=fqdn,DC=domain,DC=com
DomainUser=DomainUserWithAccountOperatorRights
DomainUserPassword=P@sswordForAboveAccount
;install apps (for DIA images only)
Application001=App1
Application002=App2

[Call Centers]
UserLocale=en-US
SystemLocale=en-US
InputLocale=en-US
Country=244
TimeZone=Pacific Standard Time
UILanguage=en-US
Prefix=CCTR-
Suffix=
Domain=fqdn.domain.com
OU1=OU=OU=Call Centers,OU=Workstations,DC=fqdn,DC=domain,DC=com
OU2=OU=HR_CallCenter,OU=Call Centers,OU=Workstations,DC=fqdn,DC=domain,DC=com
OU3=OU=IT_CallCenter,OU=Call Centers,OU=Workstations,DC=fqdn,DC=domain,DC=com
DomainUser=DomainUserWithAccountOperatorRights
DomainUserPassword=P@sswordForAboveAccount
;install apps (for DIA images only)
Application001=App1
Application002=App2