Last reply by 12-01-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Autorotation on Dell 5482 doesn't work

Inspiron 5482 2-in-1

Hello. Recently I updated BIOS on my Inspiron 5482 2-in-1 (i3-8145U 4Gb SSD 256Gb Intel UHD Graphics 620 14 FHD IPS) and after that autorotation doesn’t work. I’ve done everything I found in the internet, but it doesn’t help. What I’ve done: I installed different versions of Windows: Windows 10 1909, 20H2, 22H2; Windows 11 the latest version. I tried to install drivers firstly from official site and then from Windows update center. I’ve changed values in registry for autorotation (Enable, SensorPresent, SlateEnable, LastOrientation). I’ve installed different BIOS versions. I’ve launched sensor’s services manually.
After I install a new Windows there is no Rotation Lock button. I can only turn it on by modifying registry. The most interesting thing is that SensorExplorer from Microsoft Store can see all the sensors correctly (including Simple Orientation Sensor, which shows correct information about rotation in this program), but when I flip my laptop in tablet mode (rotation lock turned off), the autorotation doesn't work.
There are no unknown devices in device manager. I've tried to install nearly all versions of drivers from official Dell website.
I think the problem is in Intel ME firmware. It is the only thing that cannot be downgraded. So, support, please help me to turn on autorotation.

Replies (3)
5 Rhenium

Please check to see if the Rotation lock is turn on? You could do this by typing Settings onto [Cortana] search box, select System, Display and then turn on Rotation lock.


initially it is grayed out, but when I flip laptop to the tablet mode it allows me to turn on and off Rotation Lock. Autorotation doesn't work regardless this option.  

2 Bronze
2 Bronze

I'd like to ask Dell developers to pay attention to the latest Bios update 2.17.0 which contains Intel Management Engine Firmware update. I think that it can cause my problem with autorotation as it is the only thing that can't be downgraded. I tried to install nearly all the versions of BIOS, but there is always a message that ME Firmware is already up to date. Could you check if it may be conected with each other? 

Latest Solutions
Top Contributor