Inspiron

Last reply by 11-07-2021 Unsolved
Start a Discussion
3 Argentum

Dell 7706 with WD19 - UHD support

Hi.

I own the upper combination and also a WD19TB. I get UHD 60Hz working for the external monitor with WD19TB only but from the specs it should be possible with single monitor also with WD19. Perhaps it is constrained by 7706 DisplayPort support but I cannot find any specification for DisplayPort over USB-C with 7706. Is there something wrong or simply not supported?

Cheers

Nils

Replies (12)
7 Thorium

@Augur  That system uses Core 11th Gen CPUs, so it should support DisplayPort HBR3 over USB-C and therefore should be able to run 4K 60 Hz through a regular WD19 (as long as you don't have any other displays connected).  However, I've recently seen multiple topics posted here about multiple systems capable of HBR3 that are stuck at 4K 30 Hz with the WD19.  So it looks like there may be some issue with the WD19 that prevents these systems from running as expected.  Checking the WD19 Downloads page here, it looks like the most recent firmware as of this writing was released in late July 2021, and the problem reports I've seen have been more recent than that, so there may be an issue that will require another firmware update.  You might just need to check that Downloads page occasionally to see if any new updates get posted.  I realize that doesn't help you today, but unfortunately this may be another example of a tech product that SHOULD work a certain way not ACTUALLY working that way.


Mh, perhaps will open a ticket or perhaps somebody from Dell can comment it here. 

@jphughan I checked the Gen 11 specs and there HDMI 2.0 is supported but the Laptop does support HDMI 1.4 officially. Is monitor support perhaps constrained artificially because it is a middle class model?

@Augur  It’s true that Intel’s GPU specs can potentially be constrained by what the system manufacturer decides to design. For example if the GPU can handle four displays but there aren’t enough outputs on the system to run that many, then that particular system wouldn’t be able to run four displays. But I personally don’t think that is what’s happening with the dock. This sounds more like a firmware issue to me. But since you mentioned outputs, what output on the dock are you using? Have you tried any others? I know that with both the WD19 and WD19TB, some users have worked around various glitches by using the USB-C port on the back of the dock as a video output. If your display has a DP input I’d suggest a USB-C to DP cable. If it only has HDMI, then go with USB-C to HDMI 2.0. That shouldn’t be necessary, and I don’t even know if it will solve this specific issue, but sometimes workarounds that should be unnecessary do solve issues.


3 Argentum

Let me add that after disable FreeSync in the monitor I can reach UHD with 30Hz. So additional 30Hz are missing according the manual...

I upgraded from WD15 to get most out of my monitor but actually the max. output is the same...

Hi


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

3 Argentum

As I own some Dell models and also my company I tested it with a DA300 mobile dock. My monitor is driven correctly with UHD 60Hz. So it looks like a bug for me with WD19?! Or is there a explanation for this different behavior of the docks?

7 Thorium

@Augur  The DA300 is a great data point to have.  I hadn't seen that before.  That reinforces my suspicion that in cases where this issue exists, the problem is with the dock firmware rather than some issue that affects multiple systems.  The WD19 and DA300 should behave identically in this regard because they both configure the USB-C link to support video and USB 3.x data, and both support DisplayPort HBR3 over USB-C in order to achieve 4K 60 Hz even in this USB-C link configuration.  At least that is what is supposed to happen.  Obviously the WD19 isn't behaving as designed in certain cases.


3 Argentum

@jphughan @DELL-Cares : The situation is like this:

DA300: 4k 60Hz
WD19: 4k 30Hz

DA300 behind WD19: 4k 30Hz

It seems that somehow WD19 dock not get the bandwidth trough that is needed. If this is explainable it would be fine but if this is a bug in the docks firmware I would like to get it solved. Actually I cannot find any good information about it.

7 Thorium

@Augur  The explanation is that the dock is not operating as designed. The documentation for both products, which you can find on Dell Support, indicates that they support 4K 60 Hz when paired with a system capable of DP 1.3/HBR3 over USB-C. Your system supports that, but your system and others do not get 4K 60 Hz output through a WD19. I strongly suspect a firmware issue here. Unfortunately, wanting to get it solved is unlikely to result in a fast solution. I already raised this issue with an internal Dell contact after seeing the other reports of this problem I alluded to earlier, since that person has previously been helpful in getting problem reports like this to the people in a position to fix them, but I haven’t heard back on this yet. And even when I have on previous issues, firmware fixes take time to investigate the problem, find a solution, test it, etc.


Top Contributor
Latest Solutions