Inspiron

Last reply by 01-14-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell Inspiron Plugged in, not charging

As in title, Inspiron laptop powers laptop, but usually does not charge. occasionally it will randomly offer charge again but i can find no reason why it suddenly starts working again. sure enough once taken out and reinserted, it no longer charges again. 

Have previously sent laptop back to Dell because of issues with the charger, although it wasn't the same issue. 

Replies (15)
Admin
Admin

Thank you for your message. I will be glad to look into this for you.

 

Are you using original Ac adapter shipped with the computer?

 

Restart the computer & tap F2 to get into BIOS & check the status of the AC adapter & battery.

 

Run a hardware diagnostics by following this link http://bit.ly/2fJuGXB & check if there is an error.

 

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Dell-Sreejith R) & send a private message with the service tag, registered name & email address.


Dell-SreejithR
Social Media Support
#IWork4Dell

Thank you for you response sreejith, i am using the same adapter that came with purchase. And i have checked the bios menu, was able to check battery health, but am not sure how to check ac adapter status? Battery health status is ‘this battery is performing normally’. Thanks

Also probably worth noting is that since day of purchase i would randomly get an error message telling me that the wattage on my adapter is incorrect and the battery would probably not charge. However, the battery did charge for years, but i no longer get this message now that it actually doesnt charge

Not sure if this is what you were looking for, but i just found a section in the bios menu. ac adapter type : unknown. Thanks.

The unknown status means AC adapter isn't being detected in the BIOS, therefore battery will not charge. Anyway possible, you could try another adapter to see if it will be detected in the BIOS?  

AC Adapter Not Powering on the Computer or Charging the Battery

http://www.dell.com/support/article/us/en/04/sln128918/ac-adapter-not-powering-on-the-computer-or-ch...

Yeah was thinking this was probably the best way to go initially. Thanks for your help mate, ill have more info when it arrives

:BigSmile:

The status of the AC adapter should be listed under the main tab or in battery information. The adapter should say it's type - example: 45W).Please wiggle the adapter's end while checking it in the BIOS 

Hi, I have a Dell 7559 Laptop that has worked just fine for ages, then suddenly last week when I started the laptop up it had just 2% of battery life left and although the battery charge indicator shows it charging on AC mains for about 4 swips of the indicator, it then stops and the battery will not then charge. Works just fine while plugged into the mains, but that's not too good when I need to take it out and about. Suspected the battery, so changed that this morning and no change. Run the diagnostics and it states both battery and charger are correct and working fine. Tried changing the 'Battery Charge Configuration' from 'Adaptive' to 'Standard' and that didn't change anything. Tried disconnecting the AC Adaptor and battery, pressing the Power button for 20 seconds, then reconnecting battery and ac again and that didn't work, so now run out of ideas. Any help would be much appreciated at this stage. Thank you

Hey, I have a very similar problem as OP. details such as the warnings since purchase, the ac adapter appearing as unknown in the bios settings are all the same. I was able to try a friend's adapter and it was able to recognize it and charge the battery. i checked the bios just to make sure and sure enough the bios settings showed it to be 130w as it should. my friend and i both have a dell inspiron 15 7000 gaming edition. he got the model with the 1050ti and the SSD pre installed, two months after I got the model with the normal 1050 and the HDD. his adapter and mine both have the same rated 130w, 19.5v, and 6.7a. we hooked it up to a voltage meter and found mine came out at around 19.4v and his was 19.9v. our model numbers are different, mine being LA130PM121 and his being DA130PE1-00, these are the only differences we could tell. any help would be appreciated.

Top Contributor
Latest Solutions