Highlighted
1 Copper

G7 17 7790 extremely hot when in sleep mode

Jump to solution

I recently purchased a Dell G7 17 7790 laptop. I often use Sleep Mode when I'm not using my laptop. On many occasions, I've noticed the temperature around the back portion of the keyboard gets extremely hot - where the power/fingerprint reader button - with temps approaching and/or exceeding 210°F; I know that's the temp because, when I awaken the laptop, I use the Alienware Command Center to observe the current temp. The CPU and System fans immediately kick in to cool the system down. While that cooling happens quickly, this is very concerning to me. I do not understand why the temperatures get so hot. I mean, at times, it's almost too hot for me to touch the power button. Is this a known issue?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
3 Zinc

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

Sounds like connected standby (i.e. computer is not entering S3 sleep mode when you close the lid). You can confirm this by opening the command prompt and entering 'powercfg -a' - this will show you whether or not S3 is enabled.

You might be able to enable S3 sleep in your BIOS. If not, the best way to mitigate this issue is to disable network activity while in sleep mode and enable hibernate after 30-60 minutes (these options are available in the power and sleep settings).

View solution in original post

0 Kudos
8 Replies
Highlighted
1 Copper

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

My G7 laptop does not get as hot as yours, but I am also worried that from time to time, it is warm when I wake it out of sleep, after several hours left alone. The worst part is that sometimes, my battery drains when I leave it unplugged. I then lose the work I had up and running and have to reboot the laptop. I wonder what may cause this and if there is a workaround.

0 Kudos
Highlighted
1 Copper

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution
the computer does not go to sleep.
Therefore, it consumes batteries and is hot.
0 Kudos
Highlighted
Moderator
Moderator

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

HI,

 

I've replied to you over a Private note.

Please check and respond so that we can take the case further.

 

Prajwal P


DELL-Cares
Social Media Support
#IWork4Dell
0 Kudos
Highlighted
1 Copper

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

Same issue here : very hot after one hour and 60% battery consumed

0 Kudos
Highlighted
1 Copper

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

I purchased my Dell G7 17 7790 on January 13, 2020, from Best Buy. Apparently no fix has happened since mine is also heating up while on suspend. So is there a fix on the way?

0 Kudos
Highlighted
1 Copper

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

I have the same problem, is there a resolution to this ?

0 Kudos
Highlighted
1 Copper

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

I just got mine yesterday and can confirm it doesn't sleep, seems to be an issue with the BIOS if I had to guess even though its enabled currently in the  BIOS, funny thing there is a "Block Sleep" in the BIOS so I'm wondering if its actually enabled even though it says its not. Regardless I just set it to hibernate when I close the lid for now since sleep doesn't work.

 

Update: Sometimes it actually seems to sleep, turning off the keyboard and power light, other times it actually just turns the screen off, seems to be a hit or miss and its random.

0 Kudos
Highlighted
3 Zinc

Re: Dell G7 17 7790 extremely hot when in sleep mode

Jump to solution

Sounds like connected standby (i.e. computer is not entering S3 sleep mode when you close the lid). You can confirm this by opening the command prompt and entering 'powercfg -a' - this will show you whether or not S3 is enabled.

You might be able to enable S3 sleep in your BIOS. If not, the best way to mitigate this issue is to disable network activity while in sleep mode and enable hibernate after 30-60 minutes (these options are available in the power and sleep settings).

View solution in original post

0 Kudos