Inspiron

Last reply by 01-14-2022 Unsolved
Start a Discussion
1 Copper
1 Copper

G7 USB-C Intermittent Display (power only, no data)

Hi all,

I'm having an issue with my Dell G7 where the display output from USB-C only works intermittently. What's odd is that it seems to work once in the morning after the laptop and monitor have been off all night but then once I unplug it to do something elsewhere in the house and come back, the monitor won't detect the signal. I've checked with multiple cables and my housemate's laptop and that connects fine. If I plug my phone into the port, it charges but I get no data transfer like with the other USB ports.

Another strange thing is that when I plug it into the monitor and it works, I get a message that says the laptop isn't charging. As far as I know, the laptop doesn't support charging over USB-C but my monitor (LG 32UN880) can send power so I'm wondering whether plugging it in that first time trips something in the controller that stops it being able to transmit data/displayport.

Any help is greatly appreciated!

Replies (6)
Moderator
Moderator

We tried reaching you on a private message asking for the Service Tag but did not receive a response. Please feel free to reply to the private message whenever you are available.


Social Media Support

#IWork4Dell
Find your Service Tag

2 Bronze
2 Bronze

I am also experiencing this issue with intermittent connection of the USB-C port. My cables and monitor hardware are perfectly fine, they work with another USB-C Dell laptop I use. Any help is appreciated.

2 Bronze
2 Bronze

I am also getting this problem with monitors not working over USB C after about 4 hours. Powering down overnight seems to reset the port but not for a full days use. I wonder if it is a common fault to this model, that many people do not experience because they are not using USB C? Drivers are up to date and hardware checks do not identify any issues.

2 Bronze
2 Bronze

I have the same Issue. Has there been any resolution or steps to try.

2 Bronze
2 Bronze

I have this same issue with the G7 7500. I'd love to have some sort of resolution or acknowledgement from Dell.

2 Bronze
2 Bronze

I searched through the forums here and found a solution for my particular problem. I downgraded the bios on my G7 7500 from 1.12.0 to 1.5.0 and my USB-C part immediately started working again (both data and power). Previously, my USB-C port would only rarely provided data but would always provide power. I did not go through the various BIOS versions to figure out which one broke the USB-C implementation, so it's possible a version newer than 1.5.0 has a working implementation. 

 

The solution at https://www.dell.com/community/Inspiron/BIOS-Update-1-18-1-breaks-USB-C/m-p/7891310#M119812 are the basic steps I followed.

Top Contributor
Latest Solutions