Inspiron

Last reply by 04-07-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

How to disable Nvidia graphic card? Inspiron 5501

My laptop is Dell Inspiron 5501, with two graphics cards:

- GPU: Intel Iris Plus Graphics G1
- GPU: NVIDIA GeForce MX330

OS: Manjaro Ornara 21 KDE. I want to disable Nvidia. My BIOS version is 1.4.3. I have no idea why Nvidia is working even if I coding. I found that its temperature is 45*C. I’ve try to find something in BIOS, but this new version is so confusing. Can you help me to disable Nvidia and make Intel as primary?

Replies (5)

In a running notebook, the mainboard is likely in the 40-50 C range -- so it's entirely possible the GPU is at 40 C even if it's not being used.

In any case, this is a software-controlled hybrid -- the GPU in use is controlled by the drivers you have loaded.  You cannot select the GPU at the firmware level.

 

I see, but you said your Nvidia works when it is needed, so how can you explain that my Nvidia is ~45*C? I am not playing games and not working with graphics. Home temperature is 20, so i think 30*C for not working Graphic Card is top.

@fireberd 

The BIOS options are listed in the service manual, starting at page 63.  I don't see an option listed to disable the NVIDIA.

Inspiron 5501 Service Manual (dell.com)



I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 Gaming 5577 Laptop

Home Built Desktop PC with Gigabyte Designare Z390,  i9 9900K CPU

Windows 11 64 bit Pro  SSD drives. Cakewalk by BandLab and Studio One 4.6 Pro Recording Studio Software, MOTU Ultralite MK5 recording interface unit
.

Dell S2719DGF Monitor

I am not on Windows. I am using Manjaro Linux, based on Arch. I am asking if there is an option to do it in BIOS or somehow through command line

@fireberd 

8 Krypton

Usually, when a laptop has two video devices, the Intel is primary and the NVIDIA is only for gaming.  Its how my Inspiron 5577 is configured..

If yours is defaulted to the NVIDIA you can disable it in the Device Manager.  RIGHT click on the "Windows" start button (bottom left of screen) and then LEFT click Device Manager.  The Intel and NVIDA should be listed under "Display Adapters".  RIGHT click on the NVIDIA entry and then LEFT click Disable device.  This should force it to use the Intel video.  

I use my 5577 in my recording studio and do not want or need NVIDIA for recordings studio ops and the procedure listed is how I disabled NVIDIA in the 5577.

 

 



I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 Gaming 5577 Laptop

Home Built Desktop PC with Gigabyte Designare Z390,  i9 9900K CPU

Windows 11 64 bit Pro  SSD drives. Cakewalk by BandLab and Studio One 4.6 Pro Recording Studio Software, MOTU Ultralite MK5 recording interface unit
.

Dell S2719DGF Monitor

Top Contributor
Latest Solutions