SebasJ
1 Nickel

Inspiron 7567 Black screen and no response

I've just bought a new Dell Inspiron 15 Gaming 7567. As soon as I booted up the notebook, it installs Windows 10 Home Single Language and updates to Windows 10 version 1803 (april 2018 version). Long story short, the notebook has a serious issue managing power and standby mode.

Randomly (I wasn't able to find a pattern for this) the screen goes black as in standby mode, the computer doesn't activate to anything (keyboard or mouse, trackpad or wireless mouse, external keyboards, etc.,) but some functions still work, for example keyboard backlight. Power button or closing the lid does nothing at all (it should put the notebook on standby mode) and the only solution is holding the power button for 4 seconds until the notebook shuts down, hence losing the work you've been doing.

This issue has been reported previously in the following thread: https://www.dell.com/community/Laptops-General/Black-Screen-with-Backlight-Still-On-Dell-Inspiron-15...

The solution on that thread was updating the BIOS, but it didn't work in my case as I had already updated BIOS and the issue was still on.

In order to solve this I tried the following actions:

  • Check if this happens only in Windows or if it is a system-wide issue. I went to the set up (pressing F2 at boot) and stayed there for 2 hours. Screen perfectly fine, so I discarded a BIOS issue.
  • Updating drivers: I tried all three known methods: updating with Dell utility, manually installing drivers, and installing vendors drivers (i.e., installing Intel drivers and not Dell drivers). 
  • Updating BIOS: version 1.6 installed since day 1, no issues.
  • Fiddling with BIOS settings: enabling and disabling SpeedStep and C states, restoring defaults (factory defaults and bios defaults)

No matter what, the issue stayed. After playing for a while with power settings, several DCOM alerts in Event Viewer including RuntimeBroker and other COMs, finally I made a clean install of windows 1803 offline.

I deactivated driver update, and manually installed driver by driver to find which was the one causing the issue. Finally, there are five drivers that I won't install, all related to Intel (chipset and thermal framework):

  • Chipset |Intel Serial IO Driver
  • Chipset |Intel Dynamic Platform and Thermal Framework
  • Chipset |Intel Management Engine Interface Driver
  • Network |Intel 8265 WIFI Driver (I'm sure this one isn't the culprit)
  • Chipset |Intel Chipset Device Software Driver

One of those apparently is the troublesome one. I will wait until there are new drivers to see if this gets solved and, for now, I'm not going to install any other driver. Intel SpeedStep is working, C states enabled and the computer is on the safe side temp related (normally it is working at 45°C on Dell sensor, processor sensor show lower temps unless I'm processing somethig -I work with statistics and big databases-).

I wanted to know if anyone has had this issue and found a better way to solve it. For now everything is working but I don't like my Device list showing a lot of unknown devices (probably all related to Intel devices, chipset and etc.).

Best regards,

Sebastián

Edit: forgot to say specifically my model: 8GB RAM i7700HQ 1TB HD NVidia 1050Ti

 
2 Replies
jpjp21
1 Copper

Re: Inspiron 7567 Black screen and no response

I do have the same issue now. My Laptop is Dell Inspiron 13 7370. Did the deactivation of those 5 drivers solved your issue totally? I am afraid to uninstall mine because it might cause bigger issues. Please let us know. Thanks

0 Kudos
SebasJ
1 Nickel

Re: Inspiron 7567 Black screen and no response

Sorry I didn't update. Yes, apparently uninstalling those drivers fixes the issue. I had no response from Dell at all. 

I waited until new drivers were launched (the July drivers), and installed the new drivers but the issue kept going on, so I uninstalled again and everything seems to be fine. The only update I kept is the BIOS update. Since I uninstalled those drivers, this issue didn't happen again.

Temp, throttling and everything else is working fine so my bet is that one or more of those drivers is the culprit. I use my laptop for work (data analysis) and it thottles perfectly (meaning, when processing big databases in SPSS, which is a resource intensive task, CPU accelerates and fans kick in until processing is done).

Battery life is good (I'm getting approximately 6 to 8 hours, using the computer), so there seems to be no issues without those drivers. I'm trying to pin down which one of those is the culprit but frankly I didn't have the time to check that. 

In my experience, uninstalling those drivers fixes the issue and there are no collateral damages. I hope this helps!

Best,

Sebastian 

0 Kudos