KEDSON42
1 Copper

Inspiron Gaming 7567 Wireless Problem - Doens't recognize

Hi guys. I have a weird problem which is driving me crazy.

 

I have a Inspiron 15 Gaming 7567. It came with ubuntu, but I bought a Windows 10 PRO 64x and installed on it.
So far so good.

The problem is: when I start the pc, Windows doesn't recognize wireless connection. It has a red "x" on it and the drive is gone on Control Panel > Devices Manager. It's like the notebook doesn't even have any wireless adapter. 

Funny enough, the only way I can make wireless work is reinstalling BIOS FIRMWARE. When I do this, everything works fine. But after shutting down the pc, the next day here we go again, windows doesn't recognize wireless and I have to reinstall BIOS FIRMWARE to make it work.

I've never seen nothing like it. So far i've tried different windows setups. Literally installed all the latests drivers from DELL, including BIOS FIRMWARE.

I've also tried using the generic drivers that windows installs by itself.

But nothing works, and I have a feeling it's something related to BIOS, since I have to reinstall it everyday to make it work on windows. Or something about the compatibility between the wireless adapter and windows, because I spent the first days using with ubuntu and didn't notice any problem.

Can somebody help me with this weird problem?

0 Kudos
1 Reply
8 Krypton

Re: Inspiron Gaming 7567 Wireless Problem - Doens't recogniz

Have you had any trouble keeping the time and date accurate in the system? My point is that even though it is a newer model, could the CMOS battery be giving you trouble?




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built ASUS B450-F Gaming with Ryzen 5 2600X
Real work on an Inspiron 15 5575
0 Kudos