Highlighted
elmolesto
1 Copper

Installing a SSD M.2 SATA in Inspirion 15 7567

I have a Dell 15 7567 laptop, which came with a rigid 1tb disk. A few days ago I installed an SSD Crucial MX500 M.2 250GB. The OS migration from hhd to ssd was done perfectly and I was able to start windows 10 from the ssd. But my question is this: in the bios I changed the RAID mode to AHCI, because from what I read out there, the sdd performance would increase. But when restarting the laptop, the screen remained in the Dell symbol and after a couple of times it entered a screen that told me there was a hardware problem. I went back to the bios and changed back to RAID and the problem was solved. What would be the problem to solve? Do we have to make more changes in the bios? Thank you very much for answering and sorry for my English. I used the Google translator.

0 Kudos
2 Replies
ejn63
4 Ruthenium

Re: Installing a SSD M.2 SATA in Inspirion 15 7567

It is Windows you need to reconfigure - not the hardware/firmware.  

https://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-oper...

0 Kudos
Saltgrass
4 Germanium

Re: Installing a SSD M.2 SATA in Inspirion 15 7567

If the M.2 drive does not have it own NVMe controller, you will not probably see a performance increase. 

In addition, my recent testing with a Samsung drive showed about the same performance when using the Samsung NVMe or the Intel SATA/PCIe Premium Controller.  You might check and see what controller is being use while in RAID mode by looking at the Device Manager.

Leaving it in RAID might be best.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos