Highlighted
DavoB
2 Bronze

Linux Inspiron 13 7380 wont sleep

Jump to solution

I have a Inspiron 7380 running Ubuntu 18.04. One of the reasons I choose it was good battery performance but that is negated somewhat by its inability to sleep.

 

As per https://certification.ubuntu.com/hardware/201807-26324/ I understand it cannot Hibernate but I still expected (and need) it to sleep. There still is a distinction between Sleep and Hibernate isn't there ? When I close the lid, it does appear to head for a sleep mode, and come out of it normally but battery usage remains high and if I tuck it into my bag, it gets warmer than it should ! dmesg says -

...

[134374.573300] PM: suspend entry (s2idle)

[134374.573301] PM: Syncing filesystems ... done.

[134374.580568] Freezing user space processes ... (elapsed 0.007 seconds) done.

[134374.588136] OOM killer disabled.

[134374.588136] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.

[134374.589290] Suspending console(s) (use no_console_suspend to debug)

[134380.171895] acpi INT3400:00: Unsupported event [0x86]

[147673.385395] acpi INT3400:00: Unsupported event [0x86]

[147703.482821] OOM killer enabled. [147703.482822] Restarting tasks ...

[147703.485721] [drm] RC6 on [147703.486998] done.

[147703.501382] thermal thermal_zone8: failed to read out thermal zone (-61)

[147703.553003] PM: suspend exit

....

 

(edit - better job of formatting)

Davo

Tags (3)
0 Kudos
2 Solutions

Accepted Solutions
thomas_w1
1 Copper

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Apparently, this is an issue with similar laptops see https://bugzilla.kernel.org/show_bug.cgi?id=199689.

Did you try the suggestion in comment 76 of that bug?

0 Kudos
DavoB
2 Bronze

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Thomas, sorry I have not replied earlier, have been travelling and did not take the Dell with me (was pretty useless unless you have reliable power).

Yep, your suggestion looks to be the case, the 7380 has the same problem. And setting S3 or deep sleep seems to have fixed it. I just let it sleep for 3 hours and it appears to have used about 3% of battery in that time, thats pretty IMHO !

Thanks very much for the suggestion !

For those following along from home, what I have done is told the kernel that it should use S3 instead of S2, I don't know the difference, it appears to wake just as easily and all works as expected except the battery has not discharged (much) while sleeping.

As root, edit /etc/default/grub, find the line that says

GRUB_CMDLINE_LINUX=""

and add a parameter so its like -

GRUB_CMDLINE_LINUX="mem_sleep_default=deep"

(if there is already a param there, add the new one after a space)

And, still as root, run this command -

grub-mkconfig -o /boot/efi/EFI/ubuntu/grub.cfg <enter>

(Depending on your distro, might be grub2-mkconfig and the grub.cfg may be in another, similar dir)

Reboot and enjoy you new found ability to sleep well !

Thanks Thomas

Davo

 

0 Kudos
6 Replies
DavoB
2 Bronze

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

OK, one of those sad people who reply to their own questions....

There is a firmware, BIOS update, 4th April. I have applied it and will report back on what, if at all it fixes.

But impressions so far, now get several new ACPI messages -

ACPI Error: Thread 277950080 cannot release Mutex [PATM] acquired by thread 1555070976 (20170831/exmutex-416)

 

ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.ECDV._Q66, AE_AML_NOT_OWNER (20170831/psparse-550)

 

And, of course, a BIOS update locks the Windows partition again. So, be careful if you need it ....

Will report back ......

0 Kudos
DavoB
2 Bronze

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Nope, still answering my own question. The April 4th, 2019 BIOS patch did not solve the problem.

The Inspiron 13 7380 still won't sleep. Went from 75% to 64% battery in an hour of (nominal) sleep.

 

Not impressed Dell.

 

Davo

0 Kudos
DavoB
2 Bronze

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Another note however.

While it still chews through battery while asleep, I have noticed that it no longer puts entries in (eg) syslog. Before, that is before the BIOS update and a set of recent Ubuntu updates, the logs were full of things like regular DHCP requests and other housekeeping tasks. Now, we see the going to sleep process, some time goes by (according to datestamp) and then, the wake up processes.

But, even when apparently not doing anything at an OS level, its still using battery power.

Sigh. My last laptop was less than $500 ASUS, every thing worked. I pay more than three times as much and problems (of which this is just one). Must be a lesson in there somewhere....

Davo

0 Kudos
thomas_w1
1 Copper

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Did you try Ubuntu 19.04? That has a much newer Linux 5.0 kernel and the issue might be solved. I was considering this issue so am curious what you find.

0 Kudos
thomas_w1
1 Copper

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Apparently, this is an issue with similar laptops see https://bugzilla.kernel.org/show_bug.cgi?id=199689.

Did you try the suggestion in comment 76 of that bug?

0 Kudos
DavoB
2 Bronze

Re: Linux Inspiron 13 7380 wont sleep

Jump to solution

Thomas, sorry I have not replied earlier, have been travelling and did not take the Dell with me (was pretty useless unless you have reliable power).

Yep, your suggestion looks to be the case, the 7380 has the same problem. And setting S3 or deep sleep seems to have fixed it. I just let it sleep for 3 hours and it appears to have used about 3% of battery in that time, thats pretty IMHO !

Thanks very much for the suggestion !

For those following along from home, what I have done is told the kernel that it should use S3 instead of S2, I don't know the difference, it appears to wake just as easily and all works as expected except the battery has not discharged (much) while sleeping.

As root, edit /etc/default/grub, find the line that says

GRUB_CMDLINE_LINUX=""

and add a parameter so its like -

GRUB_CMDLINE_LINUX="mem_sleep_default=deep"

(if there is already a param there, add the new one after a space)

And, still as root, run this command -

grub-mkconfig -o /boot/efi/EFI/ubuntu/grub.cfg <enter>

(Depending on your distro, might be grub2-mkconfig and the grub.cfg may be in another, similar dir)

Reboot and enjoy you new found ability to sleep well !

Thanks Thomas

Davo

 

0 Kudos