1 Copper

Need help to boot USB on UEFI mode (Bios version A05)

Jump to solution

Hey guys!

I have an Inspiron 5448 and I'm trying to dual boot Ubuntu and Windows 10 on it, but I can't boot USB on UEFI mode. I have already searched for a solution over the internet and I think this can be near to the solution: https://askubuntu.com/questions/726938/how-to-boot-from-a-usb-in-uefi-mode-on-a-dell-inspiron .

But I couldn't understand it totally.

It's important to say that when I access the boot manager, the USB only appears on the legacy boot list, while the Windows Boot Manager appears on the UEFI list.

BIOS version: A05

 

Need Help!

Reply
1 Solution

Accepted Solutions
Highlighted
1 Copper

Re: Need help to boot USB on UEFI mode (Bios version A05)

Jump to solution

Thx for your help!

I discovered that I had created a Legacy USB, so it wouldn't work anyway.

But after this I got the minimal bash line editing ... error, and this time the iso was corrupted.

It's solved now! I downloaded the iso again and created a new bootable usb (using linux and gparted this time)

It's solved!

View solution in original post

Reply
2 Replies
Highlighted
6 Gallium

Re: Need help to boot USB on UEFI mode (Bios version A05)

Jump to solution

@BrenoHS  If you want to boot from temporarily attached USB devices in UEFI mode, do that by pressing F12 during startup to access the one-time boot menu. That list populates dynamically based on the devices connected at the time. By comparison, the BIOS boot menu when in UEFI mode only shows local device boot options that have been registered into the UEFI firmware. OS installers handle that for OSes they’re installing, which is why you see Windows Boot Manager, but that obviously won’t be the case for temporarily attached devices.

And FYI the F12 menu option has been around for more than a decade, even before UEFI, and it’s a much more convenient way to boot from temporary devices in general, since you don’t have to go into the BIOS, change the boot order, and then change it back again later.

If you don’t see your USB device listed in the F12 menu, make sure Secure Boot is disabled unless you’re using a Linux distro that you know supports it, and also make sure that your flash drive is using a FAT32 partition.

Reply
Highlighted
1 Copper

Re: Need help to boot USB on UEFI mode (Bios version A05)

Jump to solution

Thx for your help!

I discovered that I had created a Legacy USB, so it wouldn't work anyway.

But after this I got the minimal bash line editing ... error, and this time the iso was corrupted.

It's solved now! I downloaded the iso again and created a new bootable usb (using linux and gparted this time)

It's solved!

View solution in original post

Reply