Highlighted
1 Copper

Trying to enable WSL on my Inspiron 7580 screwed the OS beyond repair

I just wasted several hours yesterday trying to fix my Inspiron 7580. Here's what happened.

DISCLAIMER: For the record, I replaced the 1TB SATA HDD that came on the Inspiron for a 480GB SSD from Sandisk a couple of days ago. All disks were working as expected before the events I will describe below. I even installed Fedora on the second SSD just to test it out, but reformatted it right afterwards to be used as data storage.

All seemed to be running smoothly when I decided to install the Ubuntu "app" through Microsoft official app store. I tried to "install" Ubuntu directly, but it wouldn't run because WSL (Windows Subsystem for Linux) was not enabled. The error message pointed me to aka.ms/wslinstall, and the very first instruction there tells us to run

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

on PowerShell as admin. So I did, and replied "y" when it prompted me to reboot. And this is where all hell went lose.

The system did not boot into Windows. Instead, it booted into some sort of admin tool, giving me options to install from some image on a USB stick, or some more advanced options (repair UEFI boot, factory reset etc.). All of them asked me for two different 48-digit recovery codes, which I got from my MS account, but then it apparently did absolutely nothing. I tried every option available, none of them worked -- some showed error messages, other simply did nothing.

"Let's install from a recovery image provided by Dell", I said to myself. I downloaded Dell official recovery tool on another computer, ran it, downloaded the image associated to my service tag, and prepared an external drive (I did not have a 16GB USB stick around).

When I tried to boot from the external drive, it simply did not appear. I had to disable secure boot on BIOS for that to happen (even though the option said secure boot would apply to "all but external HDD").

When I finally managed to boot from the recovery tool, it would not show me the primary 128GB SSD as an option for recovery. I rebooted into BIOS, and disabled the other SSD. Another reboot into the recovery tool, and then I finally was able to select the primary SSD for recovery. It went through the whole process, and at the end, it seemed all was fine. I even booted into the fresh new image, and started updating it. "Finally!", I thought to myself. After I installed a couple of Windows updates and drivers updates suggested by Dell updater and rebooted, it got stuck on a pale blue screen with nothing else on it -- no error messages, nothing. It looked similar to the same admin tool I had faced before, but this time there was only the pale blue background. The repair tool needed repair.

I finally gave up and grabbed a fresh Windows 10 Pro installation USB I had and installed it from scratch. Now it is working back again -- and I even enabled WSL (this time not from PowerShell, but from Windows admin GUI) and "installed" Ubuntu. I lost nearly a full day on this process.

I really don't know what exactly went wrong, but I know that I followed Microsoft's and Dell's instructions to the letter, and both failed at some point. The worse for me, though, is that the repair process using tools and image provided by Dell did not work -- AFAIK it was supposed to be a clean install, I can't understand why it failed and a fresh "vanilla" Windows install worked.

Labels (1)
Reply