ALadd2
1 Nickel

Did not get response from server

Jump to solution

I'm trying to build a scripted process to create CIFS file share on a Isilon running 7.1.1.2.  When I run this command:

isi smb shares create NewShare --path=/ifs/resnas01/smb01/NewShare --create-path --browsable=true --zone=My-AccessZone --description="NewShare File Share" --inheritable-path-acl=true --create-permissions="default acl"

More often than not the return is:

did not get response from server

If I check the FS I see the directory created but it hangs right after that. If I create the directory in advance the results are the same.  Sometimes it works and sometimes not.

Anyone have any ideas for a solution?

Thanks

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
AdamFox
2 Iron

Re: Did not get response from server

Jump to solution

This is a bug. Work-around is to run it from another node. I don’t have the bug # in front of me, but I’m reasonably certain it’s been fixed in a later release (which in this case would be 7.1.1.4).

If you want to be sure, ping support and have them verify it. They should be able to find the specific bug # and verify the fix.

Hope this helps

0 Kudos
6 Replies
AdamFox
2 Iron

Re: Did not get response from server

Jump to solution

This is a bug. Work-around is to run it from another node. I don’t have the bug # in front of me, but I’m reasonably certain it’s been fixed in a later release (which in this case would be 7.1.1.4).

If you want to be sure, ping support and have them verify it. They should be able to find the specific bug # and verify the fix.

Hope this helps

0 Kudos
ALadd2
1 Nickel

Re: Did not get response from server

Jump to solution

Thanks Adam,

We're discussing upgrades to 7.2.x.x next week so I'll see what Vince knows.

0 Kudos
Yan_Faubert
2 Iron

Re: Did not get response from server

Jump to solution

Yes this is resolved in 7.1.1.4 and 7.2.0.1.  7.2.0.x bug # is 139741.

ALadd2
1 Nickel

Re: Did not get response from server

Jump to solution

Thanks Yan

0 Kudos

Re: Did not get response from server

Jump to solution

As mentioned above this is a bug which has been fixed.
(Quote: This is a known Product Bug (137885) which is fixed and targeted for 7.1.1.3)

Workaround for 7.1.1.2:

Crazy method: rebooting the SmartConnect Isilon Node
recommended method: (EMC Support)

First, we need to determine which nodes the command will fail to run on:

attempt to create a test share on each node. Use the command below replacing <nn> with the node number you are testing.

# isi_for_array -n <nn> "isi smb shares create --name=isi-test-1 --path=/ifs/data/Isilon_Support"

If the test share is successfully created, then delete it and test from the next node.

# isi smb shares delete --share=isi-test-1

On any of the nodes with an issue please follow the steps below to resolve the issue:

1. Remove the local node isi_gconfig.db (Note: this is a directory; use the -r flag to remove it)

# isi_for_array -n <nn> "rm -rf /var/ifs/isi_gconfig.db"

# isi_for_array -n <nn> "isi_gconfig_d restart" ( this recreates the db)

Verify there is a recent time stamp for isi_gconfig:

# isi_for_array -n <nn> "ps auxww |grep isi_gconfig |grep -v grep"

NOTE:

If 'ps auxww |grep isi_gconfig |grep -v grep' on that node does not show a  recent time stamp for the PID, then try 'killall -9 isi_gconfig_d' on that node.

# isi_for_array -n <nn> "killall -9 isi_gconfig_d"

2. Attempt to create a share:

# isi smb shares create --name=isi-test-1 --path=/ifs/data/Isilon_Support

If the test share is successfully created, then delete it and test other nodes.

3) if the error still persists

Verify the isi_gconfig_d service was running:

#isi services -a | grep isi_gconfig_d

isi_gconfig_d        Platform API Daemon                      Enabled


Disable the isi_gconfig_d service:

# isi services -a isi_gconfig_d disable

The service 'isi_gconfig_d' has been disabled.

Verify it was disabled using:

CLUSTER-1# isi services -a | grep isi_gconfig_d

   isi_gconfig_d        Platform API Daemon                      Disabled

Look to verify the isi_gconfig_d process was no longer running:

# isi_for_array -s ps -auwx | grep isi_gconfig_d

CLUSTER-1: root    3702 100.0  4.9 989252 820592  ??  Is   25Nov14 173:07.45 /usr/sbin/isi_gconfig_d

CLUSTER-2: root    3542  0.0  1.1 347048 182168  ??  Is   17Dec14 106:25.87 /usr/sbin/isi_gconfig_d

CLUSTER-3: root    3624 100.0  4.9 993996 823140  ??  Is   25Nov14 173:29.28 /usr/sbin/isi_gconfig_d

CLUSTER-4: root    3717 100.0  4.9 989736 816692  ??  Is   25Nov14 173:55.51 /usr/sbin/isi_gconfig_d

CLUSTER-5: root    3792 100.0  4.9 991912 821776  ??  Is   25Nov14 173:43.86 /usr/sbin/isi_gconfig_d

If it is, the only way to stop it is to kill it using killall -9:

# isi_for_array -s  killall -9 isi_gconfig_d

Verify the isi_gconfig_d  process is no longer running on any nodes:

# isi_for_array -s ps -auwx |grep isi_gconfig_d

CLUSTER-1: root   28519  0.0  0.0  7972  1348  p0  S+    3:56PM   0:00.00 grep isi_gconfig_d

enable the isi_gconfig_d service again using the following:

# isi services -a isi_gconfig_d enable

The service 'isi_gconfig_d' has been enabled.

verify the service shows enabled using:

CLUSTER-1# isi services -a | grep isi_gconfig_d

   isi_gconfig_d        Platform API Daemon                      Enabled

verify the daemon is running on all nodes:

Look to verify the isi_gconfig_d process was no longer running:

# isi_for_array -s ps -auwx | grep isi_gconfig_d

4. Attempt to create a share again and confirm if the error still exists.

# isi smb shares create --name=isi-test-1 --path=/ifs/data/Isilon_Support

5. If the error still appears, restart lwio, note this will disconnect any SMB connections to the node.

# killall -6 lwio

Confirm it restarted

# ps -auxww | grep lwio

Hope this helps

cheers

0 Kudos
tyagig
1 Copper

Re: Did not get response from server

Jump to solution

Here you will be glad to know that we are going to share one of the best portal how do i get control panel in windows 10 in order to make changes to your system settings. So if you are having same problems so make use of this platform.

0 Kudos