david_knapp
2 Iron

GUI timeout when creating new SMB share

Jump to solution

I am trying to create a new SMB share using the web gui. Version 7.1.2.2. Worked OK last week. This week every time I try to create a new share, I get Error 1 - no response from the server. I also tried this with IE and Chrome and logged in as root. Tried just waiting for a while, no luck there after an hour. I also get "no response from server" when using the command line.

Have no problem creating NFS exports. Anyone have any suggestions?

Labels (2)
Tags (3)
1 Solution

Accepted Solutions
Yan_Faubert
2 Iron

Re: Re: GUI timeout when creating new SMB share

Jump to solution

Patch 146974 contains the fix for the issue reported in this thread.  (Bug# 137885).

However, I just noticed the install instructions for Patch 146974 is missing a step to restart the isi_gconfig_d process.  I've notified the patch team but in case it doesn't make it in time, the extra steps required (at the end of the install section) are:

15. Run the following command to confirm the current PID of the gconfig process:

  isi_for_array -s "ps -ax | grep isi_gconfig_d | grep -v grep"

  Output similar to the following will appear where <PID> is the current

PID of the gconfig process:

  <Old PID> ?? Ss 0:00.01 /usr/sbin/isi_gconfig_d

16. Run the following command to stop the gconfig process:

  isi_for_array killall isi_gconfig_d

17. Run the following command to confirm that the PID for the gconfig process

  has changed:

  isi_for_array -s "ps -ax | grep isi_gconfig_d | grep -v grep"

  Output similar to the following will appear where <New PID> is the new PID

  for the gconfig process:

  <New PID> ?? Ss 0:00.01 /usr/sbin/isi_gconfig_d

  Confirm that the new PID is different from the old PID.

6 Replies
swi1
1 Nickel

Re: GUI timeout when creating new SMB share

Jump to solution

Davel, It's a bug in 7.1.1.2. Try creating the SMB share from different node. Sometimes the problem goes away on its own after some period. Still if it doesn't work, you have to apply latest SMB patch

Highlighted
Bhakti1
1 Nickel

Re: GUI timeout when creating new SMB share

Jump to solution

I had the same error when creating a SMB share and it did not create the share. I tired it again to save and create the share and it created. Seems to be a intermittent issue. Our Isilon version is 7.1.1.2.

0 Kudos
david_knapp
2 Iron

Re: GUI timeout when creating new SMB share

Jump to solution

Indeed, the problem did resolve on its own. At a later time I was able to create the share. Thanks for the reply.

0 Kudos
ed_wilts
2 Iron

Re: GUI timeout when creating new SMB share

Jump to solution

It's a collection of bugs

# isi_for_array killall -9 isi_papi_d

and then let it restart on its own.

This bug is aggravated if you've also got InsightIQ running.

Another strong possibility is that celog is acting up again and you may have to reset it.  There's a KB article on doing this or you can follow my directions below:

isi services -a celog_coalescer disable

isi services -a celog_monitor disable

isi services -a celog_notification disable

isi_for_array killall isi_mcp

isi_for_array pkill isi_celog_

sleep 60

isi_for_array rm -rf /var/db/celog/*

isi_for_array rm -rf /var/db/celog_master/*

rm -rf /ifs/.ifsvar/db/celog/*

isi_for_array isi_mcp

isi services -a celog_notification enable

isi services -a celog_monitor enable

isi services -a celog_coalescer enable

isi services -a | grep celog

Lastly, there's a rollup patch for SMB on 7.1.1.2 and you need to apply this too.  I had a couple of clusters that triggered a bug on the same day such that SMB shares couldn't even be mapped.

0 Kudos
Bhakti1
1 Nickel

Re: GUI timeout when creating new SMB share

Jump to solution

What is the patch number that couple be applied to 7.1.1.2? We are planning on applying Patch 146974 next week. Can we apply 2 patches one after the other?

0 Kudos
Yan_Faubert
2 Iron

Re: Re: GUI timeout when creating new SMB share

Jump to solution

Patch 146974 contains the fix for the issue reported in this thread.  (Bug# 137885).

However, I just noticed the install instructions for Patch 146974 is missing a step to restart the isi_gconfig_d process.  I've notified the patch team but in case it doesn't make it in time, the extra steps required (at the end of the install section) are:

15. Run the following command to confirm the current PID of the gconfig process:

  isi_for_array -s "ps -ax | grep isi_gconfig_d | grep -v grep"

  Output similar to the following will appear where <PID> is the current

PID of the gconfig process:

  <Old PID> ?? Ss 0:00.01 /usr/sbin/isi_gconfig_d

16. Run the following command to stop the gconfig process:

  isi_for_array killall isi_gconfig_d

17. Run the following command to confirm that the PID for the gconfig process

  has changed:

  isi_for_array -s "ps -ax | grep isi_gconfig_d | grep -v grep"

  Output similar to the following will appear where <New PID> is the new PID

  for the gconfig process:

  <New PID> ?? Ss 0:00.01 /usr/sbin/isi_gconfig_d

  Confirm that the new PID is different from the old PID.