Highlighted
chjatwork
2 Iron

OneFS 8.0.0.5 and mounting NFS export

Jump to solution

Community,

I am having a hard time getting a NFS export to mount from a cluster with OneFS 8.0.0.5 installed.  The stipulation was that the export has to be READ-ONLY and "No root squash."  Here is what this looks like for how I have this configured on the cluster.

                ID: 4

                   Zone: System

                  Paths: /ifs/data

            Description: Clarity Now POC - READ-ONLY; No root squash

                Clients: -

           Root Clients: -

      Read Only Clients: -

     Read Write Clients: -

               All Dirs: No

             Block Size: 8.0k

           Can Set Time: Yes

       Case Insensitive: No

        Case Preserving: Yes

       Chown Restricted: No

    Commit Asynchronous: No

Directory Transfer Size: 128.0k

               Encoding: DEFAULT

               Link Max: 32767

         Map Lookup UID: No

              Map Retry: Yes

               Map Root

                    Enabled: True

                       User: root

              Primary Group: -

           Secondary Groups: -

           Map Non Root

                    Enabled: False

                       User: nobody

              Primary Group: -

           Secondary Groups: -

            Map Failure

                    Enabled: False

                       User: nobody

              Primary Group: -

           Secondary Groups: -

               Map Full: Yes

          Max File Size: 8192.00000P

          Name Max Size: 255

            No Truncate: No

              Read Only: Yes

            Readdirplus: Yes

   Readdirplus Prefetch: 10

  Return 32Bit File Ids: No

Read Transfer Max Size: 1.00M

Read Transfer Multiple: 512

     Read Transfer Size: 128.0k

          Security Type: krb5, krb5i, krb5p

   Setattr Asynchronous: No

               Snapshot: -

               Symlinks: Yes

             Time Delta: 1.0 ns

  Write Datasync Action: datasync

   Write Datasync Reply: datasync

  Write Filesync Action: filesync

   Write Filesync Reply: filesync

  Write Unstable Action: unstable

   Write Unstable Reply: unstable

Write Transfer Max Size: 1.00M

Write Transfer Multiple: 512

    Write Transfer Size: 512.0k

Using the following command on the remote server I could not get the filesystem to mount.

$ sudo mount first-nfs.[DOMAIN].org:/ifs/data /mnt/firstCluster/

mount.nfs: an incorrect mount option was specified

What FSTAB looks like on the remote server:

#

# /etc/fstab

# Created by anaconda on Thu Nov  9 11:26:29 2017

#

# Accessible filesystems, by reference, are maintained under '/dev/disk'

# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info

#

/dev/mapper/cl-root     /                       xfs     defaults        0 0

UUID=7abb8c81-867c-419a-b4ab-40836f11ec99 /boot                   xfs     defaults        0 0

/dev/mapper/cl-swap     swap                    swap    defaults        0 0

First-nfs.[DOMAIN].org:/ifs/data /mnt/FirstCluster nfs ro 0 0

Second.[DOMAIN].org:/ifs/data /mnt/SecondCluster nfs ro 0 0


Please let me know what I could be doing wrong.




Thank you,



Labels (2)
Tags (3)
0 Kudos
1 Solution

Accepted Solutions
chjatwork
2 Iron

Re: OneFS 8.0.0.5 and mounting NFS export

Jump to solution

I was able to figure out what the issue was.  At the bottom of the NFS export configuration is settings for security that had kerberos selected and not UNIX.  I unselected all the kerberos and selected UNIX.  All Joy!

0 Kudos
1 Reply
chjatwork
2 Iron

Re: OneFS 8.0.0.5 and mounting NFS export

Jump to solution

I was able to figure out what the issue was.  At the bottom of the NFS export configuration is settings for security that had kerberos selected and not UNIX.  I unselected all the kerberos and selected UNIX.  All Joy!

0 Kudos