Highlighted
3 Silver

Problem with DNS to resolve non-FQDN hostname

Hi,

we started last week with our new Isilon and found that currently it is not possible to use short host names for accessing the SMB shares because our Windows 2008 R2 DNS server is not able to work with Isilon in a way to resolve the short host name pool1.isilon1 . If we use FQDN pool1.isilon1.subdomain.domain.de for the host everything is working fine.

We tracked that the problem only shows up with Win7/Win8 clients. With WinXP the problem does not exist.

A colleague found the cause in the Isilon answering with IPv6 DNS names but our Windows Server does not speak IPv6.

Therefore we'd like to disable IPv6 on the Isilon. Is that possible?

Regards,

daniel

0 Kudos
6 Replies
Highlighted
2 Bronze

Re: Problem with DNS to resolve non-FQDN hostname

I do not know of a way to disable IPv6 on the Isilon, but the issue you describe sounds similar to a recently discovered issue in OneFS 7.0.1.x.

The symptoms are a REFUSED response from the SmartConnect DNS server for AAAA names.


An interim solution is to setup SmartConnect zone alias using the FQDN. Or, replace the short name in

the SmartConnect zone name with the FQDN.

You can also open a support case for more detailed analysis of your specific issue.

Highlighted
3 Silver

Re: Problem with DNS to resolve non-FQDN hostname

Hi Mark,

where should we setup the SmartConnect zone alias using the FQDN?

The SmartConnect zone name is already FQDN.

Being new to Isilon: Where should I open the SR?

Regards,

daniel

0 Kudos
Highlighted
3 Argentum

Re: Problem with DNS to resolve non-FQDN hostname

How about following commands:

isi networks modify pool "subnet:pool" --add-zone-aliases=<alias FQDN>

If you have support contract with EMC go to support link and open "Online Support Home" or "Live Chat".

0 Kudos
Highlighted
3 Silver

Re: Problem with DNS to resolve non-FQDN hostname

SmartConnect zone setting already have the FQDN in their configuration.

0 Kudos
Highlighted
3 Argentum

Re: Problem with DNS to resolve non-FQDN hostname

Do you have Primary DNS Suffix defined on your Win7/Win8 Clients?

In my test environment I can access to Isilon without Domain Name.

Isilon side setting:

DNS Search List:     project.test.local

SmartConnect Zone Name of a pool:  v7

DNS setting:

  v7.project.test.local NS  cluster.project.test.local

  cluster.project.test.local A <SmartConnectServiceIP>

Win8 setting:

   Primary DNS suffix : project.test.local

I could access cluster by SMB using \\v7\ifs .

I hope this information will help you.

0 Kudos
Highlighted
3 Argentum

Re: Problem with DNS to resolve non-FQDN hostname

I don't think you can disable IPv6 on your cluster.

Do you really need to use SmartConnect for your system?

If not, for a workaround, why don't you write DNS round-robin in your DNS in stead of NS to Isilon?

0 Kudos