Isilon

Last reply by 12-07-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1016

isilon : exclusive lock file?

Migrated NetApp volume data to isilon(9.1).

When only executed ls command from Linux, got many "cannot access xxxxxxxxxxxx no such file or directory" result.

after 2~3 mins then responded ls file list result.

How to identify current behavior and root cause or any idea to trouble shooting?

NFSv3 client.

Thanks a lot!

Replies (9)
1001

Hello mubasicusr,

Which Isilon system do you have and what is your current onefs version?


DELL-Sam L
Social Media Support Enterprise
#IWork4Dell

999

Hi Sam, thanks for your reply

OneFS Version: 9.1.0.4

We have F600, H500, and A2000 isilon system at environment.

We defined access zone into from host to F600 and H500.

973

Is it set to local locally or remote? When does it occur? After a reboot or every time a client makes a connection?


Thanks,

DELL-Josh Cr
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

961

Execute ls command by every linux host if it mounted the path.

type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,proto=tcp,timeo=600,retrans=6,sec=sys,mountaddr=xxxxxxxxx,mountvers=3,mountport=300,mountproto=tcp,local_lock=none,addr=xxxxxxxxxx)

Anytime is occurring, even we reboot the Linux host, we still get this error.

#time ls

ls: cannot access xxxxxxxxxxxxxxxxxxxxxxxxx: No such file or directory

ls: cannot access xxxxxxxxxxxxxxxxxxxxxxxxx: No such file or directory

ls: cannot access xxxxxxxxxxxxxxxxxxxxxxxxx: No such file or directory

real 2m29.831s
user 0m0.047s
sys 0m0.223s

Thanks a lot! 

918

Hello mubasicusr,

How did you migrate your files from your netapp to your Isilon? Did you use emcopy, robocopy or isi_vol_copy?


DELL-Sam L
Social Media Support Enterprise
#IWork4Dell

914

Hi Sam,

We are using Linux XCP to execute data copy.

Thanks!

901

Those 2m30 or 150s look suspicious to me, like a network timeout at the TCP layer.

You can check the network condition using the relevant sections from these troubleshootung guides:

https://dl.dell.com/content/docu80766 

https://dl.dell.com/content/docu60944 

hth

-- Peter

785

Hi Peter,

Thanks for your reply.

But if it is a network timeout issue at TCP layer.

I have 2 folders that is using data uploading, one of folder normal, but other is bad.

I don't have idea for this different.

764

Does it work locally on the Isilon cluster, from all nodes?

If so, what happens on the Linus client when you create a full copy of the 'bad' folder?

Have you run a cluster health check? - see https://www.dell.com/support/kbdoc/en-us/000130893/dell-emc-isilon-healthcheck-isilon-info-hub 

(What has Dell support advised so far?)

 

Latest Solutions
Top Contributor