Highlighted
2 Bronze

2012 Precision M6700, Windows 10, Quadro K4000M stuck at 135MHz (PCI 1.1, not 2.0)

Hi folks,

First time post here, so hello everybody!

I have a weird issue: My K4000M is stuck at 135MHz, no matter what power profile, Bios (tried A15,16,17), Nvidia driver (tried a few different), GPU load 99% or not.
nvidia inspector and GPU-Z show that the bus speed is PCI-E 1.1x16, not 2.0

With Nvidia support chat, I had success once by disconnecting from my docking station (very short jump to 601MHz) and when I unplugged and re-plugged my AC, it went to 601 MHz and remained there.

Quick test of Skyrim showed 60fps, not 22.
But after a reboot -> back to 135MHz and stuck.

I only just noticed this but it must have been for a while, maybe even since upgrading to Win10 (clean install). GPU Temp has been under 40°C as far as I can remember with Win10.

Does anybody have any input or idea? 😕
Thanks so much!

Best, Andrew

0 Kudos
2 Replies
Highlighted
2 Bronze

PCI-E Bus speed limited / AC replug sometimes helps

Hi there,

I have an issue with my Dell M6700, latest bios and chipset drivers (Dell site).

My PCI-E bus is usually stuck at 1.1x16, insteda of 2.0x16, resulting in my nVidia K4000M running on minimal speed and being locked there, regardless of gpu load, power profiles or settings.

When not in the docking station, replugging the AC sometimes helps it go back to 2.0 speed and normal GPU clocks.

Any idea what might be causing this?

Thanks for any input!!

Best, Andrew

0 Kudos
Highlighted
2 Bronze

M6700 with Win10 - please check your PCI-E /GPU Speed for me :-\

Hi there,

my second post here and I am still on the same issue for a good year.
Short: My Nvidia K4000M is not running full speed in my M6700, unless I un- and replug my power adapter.
GPU-Z shows the nvidia GPU to be working at PCI-E16@1.1 speed, not at @2.0 like it should - even under GPU stress (stress test rendering). Once the plug is re-plugged, it goes up to 2.0 and the full GPU MHz clock speed as it should.

I assume this is a bug somehow with Win10. Dell are a little slow / not 100% able to test (Dell Germany for me) and I was hoping a fellow M6700 / Win10 owner could do a test.

If you would please be willing to help, it would be: Boot up your M6700, run GPU-Z (portable and downloadable on the net) and select the Nvidia GPU and check "Bus Interface" for the bus speed.
THEN click on the "?" next to it and do a stress test render - best would be on a second screen as this moves the GPU load to the NVidia.

What happens to your bus speed? Does it go to 2.0 or stay at 1.1 under load?
(If only 1.1, try unplugging and replugging your mains adapter - retest -> ???)


I have tried different drivers, Bios, Optimus on / off, Windows power options obviously (link PCI-E power management state), NVidia power options etc - been through it with NVidia support dev, no luck.
A quick test on your side might track down a broader Win10 / M6700 bug though.

Thanks for anybody testing this!!
Best, Andrew

0 Kudos