Kosiniak
1 Copper

2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

Temporary solution/workaround: disable "C-States" in BIOS, the "Performance" section.

Here are instructions how to access BIOS/UEFI settings on a Windows 10 laptop:
www.dell.com/.../SLN143038

Issue description:
My new DELL XPS 9360, CPU i7-7500U (Kaby Lake) was freezing/hanging completely under Windows 10 (most recent BIOS as of today, tried Windows without and with recent updates). There were no Windows logs preceding it. The display was frozen, audio playing in a loop the last sound, the keyboard, touchpad, external mouse irresponsive. Only recovery with a long press of the power button.

All DELL self-test passed fine, also Windows overnight memory test passed fine.

DELL service in Switzerland/Germany checked it and sent back without any repair (but still they sent it back after ONE month after I emailed them).

Tags (1)
1 Solution

Accepted Solutions

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

I had the exact same problem. With an Inspiron Kaby Lake i7-7500U, Windows 10.

I think it's an issue with the chipset, not unique to Dell.

SOLUTION - Disable PCI-Express Link State Power Management.

(Settings / System / Power&Sleep / Additional Settings / Change plan settings / Change advanced power settings / PCI Express ... Set Link State Power Management to OFF).

You can then re-enable C-States in the BIOS.  I haven't had a hang since - over a week of heavy use.

Good Luck, G.

6 Replies
majority
1 Copper

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

Same problem here (just got my XPS yesterday). Only noticed the error after updating to bios version 1.2.3 today, 1.0.7 I believe was previous bios version. Disabling C-States seems to have solved it for now, as you suggested.

0 Kudos
fraggler
1 Nickel

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

My identical laptop also suffers from this freezing problem. I will try the bios setting.

What is likely impact of disabling "C-States" ?

What with the poor WiFi and occasional inability to wake from sleep I am pretty disappointed with this extremely expensive laptop!

0 Kudos
_gerben_
6 Indium

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

3 freezes in 6 hours before disabling C-States, 1 freeze in 6 hours after disabling. This solution did not fix it completely for me.

0 Kudos
majority
1 Copper

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

Fraggler, I've noticed the wifi problem as well, I thought it was just me.

I noted there is a new bios version released, 1.3.2 I think it was, just installed it but this doesn't solve the hanging issue (dunno about Wifi). For _gerben_, not sure why disabling c-states doesn't solve your issue, maybe the root cause is different.

Anyhow, I think I will report this to Dell. Annoying having a laptop that doesn't work as expected.

0 Kudos
_gerben_
6 Indium

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

I reported the hanging issue to Dell and the C State disabling. They advised me to reinstall the OS (Ubuntu), but that also did not solve the issue. Now they have advised me to search on the Ubuntu forum...

I guess the freezing issues that I have are indeed having a different cause. Good to know that I am not the only one and that this happens under Windows too.

0 Kudos

RE: 2016 DELL XPS 13 9360, i7-7500U (Kaby Lake) freezes / hangs (C-States)

Jump to solution

I had the exact same problem. With an Inspiron Kaby Lake i7-7500U, Windows 10.

I think it's an issue with the chipset, not unique to Dell.

SOLUTION - Disable PCI-Express Link State Power Management.

(Settings / System / Power&Sleep / Additional Settings / Change plan settings / Change advanced power settings / PCI Express ... Set Link State Power Management to OFF).

You can then re-enable C-States in the BIOS.  I haven't had a hang since - over a week of heavy use.

Good Luck, G.