cbeld
1 Copper

2nd drive install issues with Dell 9550 (p56f001)

I was hoping someone could provide me with their experience when installing a 2nd hard drive on their laptop.

My laptop came with the NVMe SSD (256GB if that is relevant) and the smaller battery so that there was room for a 2.5" drive.

I am attempting to install a 2.5" SSD.  I have the cage, grommets, and interposer.  The interposer seemed to connect correctly but the SSD isn't being recognized.

I have verified that the SSD works fine (I put it in an external USB enclosure and tested it), so there is no issue there.

I feel like it is one of three issues:

  1. The interposer is bad (or not the correct one).
  2. There is a BIOS setting that needs to be changed (currently set to RAID On, as it was shipped.  Changing it prevents Windows from loading)
  3. There is an issue with the motherboard preventing it from working correctly.

I'm hoping or (2), but would be happy with (1), I just wish there was a way to test it.  There are several options available on Amazon that come with the interposer.  If anyone has a recommendation I'd be happy to take it.

Thanks in advance.

0 Kudos
6 Replies
cbeld
1 Copper

RE: 2nd drive install issues with Dell 9550 (p56f001)

Does anyone have a experience with a similar laptop?  Was wondering if anyone had success with just installing the hardware with no other changes, and/or if someone could look at their BIOS setting for storage (i.e. RAID On or another setting, etc.)

0 Kudos
jphughan
5 Rhenium

RE: 2nd drive install issues with Dell 9550 (p56f001)

Even with RAID mode enabled, both the BIOS and Windows would be able to see the second drive.  That option is there to force SATA traffic through the Intel Rapid Storage controller to allow for Intel Smart Response if you were using a 2.5" spinning drive and a small (32GB) SSD cache module in your M.2 slot.  But until you enable that option, RAID mode treats all drive as independent and makes them all visible.  So unfortunately, that would not account for your issue.

If you ever did want to change that BIOS setting to AHCI though, you might be able to get a bit more performance out of your NVMe SSD.  The reason these systems ship in RAID mode is because it's the most compatible configuration, so it's easier for the factory.  RAID mode enables the caching setup I just described for people who ordered their system that way, AND it allows Windows 7 to run on NVMe drives.  Windows 7 doesn't have native support for NVMe, but RAID mode uses the Intel controller to mask that from the OS, so as long as you use the Intel RST driver, you can run Win7 on an NVMe drive -- and the XPS 15's sister Precision system can be ordered from the factory with Win7.  But on Win8 and up where native NVMe support is available, bypassing that controller might get you some extra performance, especially if you have something like a Samsung retail SSD where you would be able to use Samsung's NVMe driver rather than the default Microsoft driver, which some users have found significantly improves performance.

0 Kudos
cbeld
1 Copper

RE: 2nd drive install issues with Dell 9550 (p56f001)

Thanks, that at least removes that possibility.  A bit more performance would be nice, but not worth the trouble (not sure what it would entail, but obviously something since it wouldn't boot up when I tried it).

I've ordered a second interposer cable in hopes that the issue is there.  If that doesn't work, I guess I'll just live without it.

0 Kudos
9 Rhodium

RE: 2nd drive install issues with Dell 9550 (p56f001)

I think you'll find you DO need to disable RAID.  The RAID setting is designed to allow the M.2 drive to act as a cache for the hard drive.  Without risk to the system, you could:

Remove the M.2 drive.

Set the system for AHCI.

If you then see the hard drive -- which you almost certainly will -- you'll know that in order to use both drives, you must have them set to AHCI (which either means an ground-up reload or a registry tweak to change Windows from RAID to AHCI).

0 Kudos
cbeld
1 Copper

RE: 2nd drive install issues with Dell 9550 (p56f001)

I'll give it a shot this evening and see what happens.

0 Kudos
Highlighted
jphughan
5 Rhenium

RE: 2nd drive install issues with Dell 9550 (p56f001)

@ejn64, RAID mode makes it possible for Intel Smart Response to be enabled, but it wouldn't prevent the 2.5" drive from being shown.  That wouldn't even make sense given that in the Smart Response case, the "primary" drive would be the 2.5" drive in the first place.  But actually even when Smart Response is being used, the 2.5" and cache module are still presented in Disk Management as separate devices, not as a single virtual disk.  At least that's how it was on the last Smart Response system I saw.  But again, the system being in RAID mode would absolutely not explain a 2.5" drive being hidden.

0 Kudos