Highlighted
jehmin
1 Nickel

Advanced Plugged In Battery not Charging AC power wattage and type cannot be determined

Dell Battery Charging Problem Complicated

Could be one of those “Mother Board” Fixes but how can we get to the bottom of this?

The question is what allows the computer to determine the adapter wattage and type?

What part can I buy and rework on the board? Honestly the computer works fine minus this part.

Something is telling the computer to not charge the battery. Regardless if HDD is in the computer. Its something hardware related.

Warranty just expired last week =(

Latitude E6530

Other working units used to  test and swap components with is E6520 and E6540

NOTE** All batteries used and cables used are factory and known to work with other latitude computers. Using extended battery + dell 130W and 90W power supply with original batteries over 78% health on dell diagnostics.

Dell diagnostics shows 100% but the current in the battery is 0. Meaning it isnt charging. Downgraded to the lowest firmware too from the highest and it didnt fix the issue.

When the PC is shut off with battery inside, inserting a power cable will turn on the battery charging indicator symbol light. After 1 second it will turn off. Same thing while the computer is running.

Upon Boot :

ALERT! AC power wattage and type cannot be determined. The battery may not charge. The system will adjust the performance to match the power available.

While running windows: Plugged in not charging.

Steps Tried:

Running windows 10 all current drivers

BIOS Update to 17 = No help

Blowing on the DC IN jack, tapping around, switching power cables + batteries.

Precharged 100% battery alone= working without charge

Pluged in without battery = working without charge

Switched DC-IN power jack from a known working e6540 = same issues

Tried unplug internal battery, battery, and unplug, reset bios = No solution.

Tried uninstall and disable battery managers from device manager= no help

0 Kudos