1 Copper

Alienware 17 Plugged in, not charging/AC Adapter not recognized

I have had my Alienware 17 for two years now. I bought it for college and being a broke college student, I really don't want to have to replace anything on this already pricy and new laptop.  Around December, it started showing the message (plugged in, not charging) above my battery icon. This concerned me, but I could just wait the problem out and eventually it would fix itself. In March, this problem happened again and I was able to uninstall/reinstall the ACPI Compliant Control Method Battery driver and it would charge again.

Well, I have this problem again and now nothing I have tried will fix it. I tried draining the power, I tried removing the battery/AC Adapter and holding in the power button for 30 seconds, but that didn't work. When it boots up, it shows a message saying that it doesn't recognize the AC Adapter. However, my PC is only running on power from an AC Adapter that apparently it doesn’t even recognize. If I even unplug my laptop, it shuts down.

Giving it time hasn’t helped, reinstalling the drivers hasn’t helped, and my BIOS is completely up to date. This is extremely frustrating because this is supposed to be a high performance laptop, and it is only two years old. I rely on this for programming, running my virtual machines upon other things while attending classes at my university. With an intense semester coming up this fall, I have to get this back in prime condition. I’m not sure where to go from here...is this a battery problem, a motherboard problem, an adapter problem? I have seen similar threads all over the internet about other Alienware laptops, however none of them have provided me with a proper solution. Any help would be greatly appreciated!

0 Kudos
1 Reply
9 Rhodium

RE: Alienware 17 Plugged in, not charging/AC Adapter not recognized

It's an adapter, jack or mainboard problem.

First thing to try is a new OEM Dell AC adapter.

If that doesn't solve the problem, replace the DC jack:




If that doesn't do it, the problem is with the charge circuit and the mainboard will need to be replaced.

0 Kudos