Highlighted
zasteriod
1 Copper

Attempting to install CentOS on Inspiron 15 7000 Gaming laptop; claims Hardware Error

I have a dell Inspiron 15 7000 Gaming. I want to replace the windows OS with Linux (CentOS) to be exact.

I have a installation disc I used to install it. I've already used said disc to install CentOS on a ProBook 4540s and the disc worked great. I am using an external optical drive.

Anyhow, the disc is not working for the Inspiron. First the message stating "press any key to enter the menu" comes up, with the options 1) CentOS 6.8 2) Install system with basic video driver 3) rescue. Regardless of what I select I get this:

Console: switching to colour frame buffer device 240x67
fb0: EFI VGA buffer device
APCI: AC Adapter [AC] (on-line)
input: Lid Switch as devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
APCI: LIid Switch [LID0}
...
APCI: Executed 1 blocks of module-level executable AML code
APCI: SSDT 000000007837b718 00651 (v02 PmRef Cpu0Ist 0003000 INTL 20160422)

Then I get repeating messages (repeats once very 30 seconds) such as:

CODE: eb 06 41 89 F4 48 85 ...
Call Trace:
[<ffffffff813163a7>] ? acpi_ns_exec_module_code_list+0xe2/0x143
...
[<ffffffff813163a7>] ? child_rip+0xa/0x20
[<ffffffff813163a7>] ? kernel_init+0x0/0x2f7
[<ffffffff813163a7>] ? child_rip+0x0/0x20

(I can provide the lines in between if requested) And occasionally I get messages at the bottom such as:

[Hardware Error]: Machine check events logged log location
disabling lock debugging due to kernel taint
switching to clocksource tsc

I've tried putting the disc contents on a flashdrive and the same thing happens. I don't understand the hardware error claim; the same disc and optical drive worked for the other machine.

0 Kudos
1 Reply
8 Krypton

RE: Attempting to install CentOS on Inspiron 15 7000 Gaming laptop; claims Hardware Error

From the looks of it, in order to run Centos, if you have a Kaby Lake (seventh generation CPU), you need Centos 7 -- the older versions do not support the newest Intel processor platform.

Your Probook uses a much older CPU -- which is why the older Centos version works.

0 Kudos