larabee119
1 Copper

RE: BIOS UPDATE A10/ A13/ A16 XPS 15 9550 4K SCREEN TERRIBLE FLICKER

Just a few days. I got it as refurbished. The first thing I do is go to Dell support and download the bios update.

After the bios update, use the latest driver from intel for HD 530 ( build 4627 ) Dell driver 4590 will crash your system. Then make sure you disable panel self refresh in Intel display driver.

Make sure you install latest driver from nvidia too.

0 Kudos
Shawtux
1 Copper

RE: BIOS UPDATE A10/ A13/ A16 XPS 15 9550 4K SCREEN TERRIBLE FLICKER

has anyone tested out the new drivers 4627_A09?

0 Kudos
Nov2015
1 Copper

RE: BIOS UPDATE A10/ A13/ A16 XPS 15 9550 4K SCREEN TERRIBLE FLICKER

Been getting Dell bios update reminder.  I so dis-trust the Dell updates ever since the screen flicker issue that dare not update without checking with the top-guns here.  Anyone tried the Dell XPS 15 9550 1.5.1 System Bios?

I see even in this year there is still talk of screen flickering?  I am currently using

Version 1.2.19

Date 22/12/2016

0 Kudos
merrillie
1 Copper

RE: BIOS UPDATE A10/ A13/ A16 XPS 15 9550 4K SCREEN TERRIBLE FLICKER

I had the flickering issue with my Inspiron 7579 when it was brand new 12 months ago and solved it after trying a zillion things but don't remember what the solution was now. Unfortunately I am back to square one after a remote access by Dell who did some updates which bought the flicker back and then got me to write a USB restore key before coming and changing the hard drive the flicker is back in laptop and constant blinking in external Dell monitor.  ( At one point before they came to install the hard drive I did a system restore to the day before they accessed it and the flicker was instantly gone, I wish I had done the USB system restore again then)

The Flickering on my laptop right hand side isn't as bad as the constant blinking on and off of the externaI monitor which is only new for my photography work. I cannot find a solution. Everything is uptodate, every driver is uptodate, and I have tried everything I have come across on Google to no avail. I have changed the HDMI to HDMI cable to a different one.

Anyone got any suggestions?

0 Kudos