Laptops General - Read Only

2 Bronze

BIOS clock slow- Not due to CMOS battery

Hey appears I'm having some issues with a slow clock.  I have an XPS M1330.  Initially, it would fall behind a few hours each day, INCLUDING the BIOS time.  Also I noticed frequent Wi-Fi disconnections, as well as when I would shut down the laptop, it would not completely shut down.  It would go into what I believe would be an "idle" state, showing the blue power LED still being lit.  I would have to then manually shut down the laptop by holding the power button.  That was the only way of getting it out of the so-called "idle" state.  So first thing I decided to try was to replace the CMOS battery which was the first suggestion.  After replacing the CMOS battery, I got about 2 weeks of flawless performance; no slow clock, and no powering off issues.  Now, the clock is running slow again and I can't seem to figure out why.  I updated to the latest BIOS (A14 I believe), which seemed to work for about a day, now it's back to being slow again.  It is not shutting down properly either.  When I check the BIOS time, it is also incorrect.  I'm not sure if this a motherboard issue or what but any suggestions or ideas would be great. 

Replies (23)
2 Bronze

I wanted to bump this because I really want to see if anyone has any idea or answers as to what this could be or how to fix it so I can save myself some money and not buy a new motherboard.

2 Bronze

Updating once the laptop's time has been going backwards?  Not sure if that means anything different than it just being slow but I wanted to see.  It's still not shutting down properly as it goes into some sort of "idle" state that can only be gotten out of by holding the power button and turning the laptop off.  Still looking for any help or answers.

7 Thorium

You might want to try and do a repair on the OS by following the info HERE.

If that does not work then the other two options are Factory restore or Clean reinstall. Note that both of these will completly wipe out your current system and unless you back up your data it will be lost. You will also have to reload all your programs that did not come preinstalled if using the Factory restore option or all the programs if doing  the clean install.

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

2 Bronze

Thanks Davet50 I really appreciate the response.  Ill check these out and hopefully I find something that works!

2 Bronze

Well I wanted to post again and update the situation...I followed the tutorial that was given in the link for a clean install of the OS and still the same issues.  Real shame to because it took a long time to get everything back up and running.  So unless there's another option I'll have to buy a new MOBO from somewhere.

5 Tungsten

On the issure of your Clock being slow. Did you check to see if your clock was set to be in the same region in which you live in.  If it is not then now matter how many times you reset it once rebooted it will revert bact to region it was setup in.


Own: Dell Chromebook 11, Alienware M11xR2


Forum Member since 2004

"If your issue was resolved, please click  Yes ".


2 Bronze

Hey Dallascowboys...yeah I'm in the right time zone.  I made sure to check that when I installed the new CMOS battery a while back.  The clock seems to be slowing at a much more frequent pace than it had been originally.  It seems to jump backwards sometimes.  For example the clock will be synced correctly for an hour's time period (say from 2pm to 3pm) and when it hits that new hour (3pm), it seems to jump back to 2pm and keep time from there, however at a slower pace.

2 Bronze


I have the EXACT SAME problems with my xps 1330.  Did you ever figure out the problem and find a solution?  Was it the MOBO?  Would really appreciate it if you can help me out.


2 Bronze

Just to add to this discussion, I am also experiencing the same exact issues for the last week. I've validated the correct bios time and windows time. within 20 minutes or so it will be back off by an hour. It is very frustrating not having this runnign correct. On a note when looking at the time in the BIOS. I had found that the clock was actually staying in place, meaning the seconds were not advancing while viewing the time in the BIOS. I'm not sure if this is just an indicator that I need to replace the cmos battery or if there is another hardware problem occurring here.

Top Contributor
Latest Solutions