8 Krypton

BIOS update keeps failing - any solution welcome

My laptop is an Inspiron 7737 running Windows 8.1 with DELL BIOS A4.

Updating BIOS to version A13 has not been possible from a Windows environment.

I''ve set up a bootable USB key using RUFUS 2.2 but the key is not recognized by UEFI and Windows just boots regularly.

Boot priority has been directed to USB storage, removable drive and DVD ... but still doesn't work.

Even using Advanced Booting, use this device and selecting each option alternatively (multiple attempts) resulted in the same Windows regular boot.

Tried booting by rapidly pressing F2, F12, Fn+F2, Fn+F12 etc... has no effect. Anyone else with the same problem? Did you find a solution?

On the bright side, I am able to boot from the same key when installed with the Windows Media Creator for Windows10 so it shows that the key is bootable.

Has anyone been able to boot from a USB key and update their drivers from BIOS / UEFI? If yes, which application did you use to set up the USB key?

Thx in advance!

0 Kudos