devomed
1 Nickel

BSOD after failure of Dell PC Checkup

Hey guys, I have had two BSOD/crashes after trying to run the Dell PC Checkup tool. Each failure has been after SMART Short Self Test showed "unknown error." After I get the BSOD, the computer restarts but when trying to boot into Windows, it is unable to detect the hard drive. It says "reseat hard drive." I did open up the laptop, and my hard drive is snug. 

I have a Inspiron 15 N5030 bought about 3-4 years ago. Everything is factory except I replaced the HD with a San Disk Extreme 250 GB SSD probably over a year ago with no problems. Running 64-bit Win 7 Home Premium Service Pack 1. Pentium Dual-core T4500 @ 2300 GHz 2.30 Hertz. 3 GB DDR2-3? RAM. 

PC Checkup shows these errors:

Check under Event Viewer in Windows and saw:

Several of these: The driver detected a controller error on \Device\Ide\IdePort0

One of these: Session "Microsoft Security Client OOBE" stopped due to the following error: 0xC000000D

This:

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}
and APPID
{344ED43D-D086-4961-86A6-1106F4ACAD9B}
to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

And this:

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}
and APPID
{344ED43D-D086-4961-86A6-1106F4ACAD9B}
to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

And this:

Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

So basically, this is beyond me. The computer actually works well. After got the "no hard drive detected" message, I did the onboard diagnostics and everything checks out completely. After I finished these diagnostics, it still wouldnt boot due to undetected HD, so I turned it off. It was able to start up from "off" and boot Windows normally. I can browse internet, open files, run programs but not do anything to scan/attempt fix of the hard drive without it crashing. It did the same thing a couple days ago after trying to scan with Dell PC Checkup.

Any advice? Any chance it could be a virus? Thanks all. 

0 Kudos