Not applicable

Bizarre power issue.

Dell Lattitude E5530.


1. When battery installed, no adapter is found. Battery won't charge. Computer will boot but not charge. BIOS says "NO ADAPTER FOUND"
2. When battery removed, adapter is found. Computer will boot. BIOS says "90W adapter".
3. When placed on Docking Station with Battery, no adapter found. Boots but won't charge.
4. When placed on dock with no battery, won't boot. If I plug an adapter into the dock and another into
the computer then it boots. BIOS then says "90W Adapter".
5. If I boot using the adapter, then plug in battery, battery LED goes out and it sees no adapter and shows battery not charging.
6. If I boot using the battery, then plug in the adapter and remove the battery, it shuts off and I have to reboot it.

What I've tried:
Updated all drivers.
Cannot update BIOS because this requires a partly charged battery AND an adapter. Comp won't see adapter when battery is plugged in.
I have tried 4 different 90W DELL adapters from Latitude computers (co-workers have same computer).
I have tried 2 other batteries besides the one that came with it.
Nothing makes any difference. No matter what combo of adapters and batteries I use, the symptoms remain the same.

Any suggestions would be most welcome!


0 Kudos
1 Reply
10 Diamond

RE: Bizarre power issue.

If you haven't changed the DC jack, that' s next:


If you have, to no effect -- or replace it to no effect, the mainboard is the faulty part.

0 Kudos