User_BG
1 Nickel

Built-in WiFi modem suddenly stopped working

Hello!

Since I couldn't find an answer anywhere, I'm going to ask you for help. The thing is, I used to browse the Internet through my Dell Vostro A860 Laptop, but yesterday its built-in WiFi modem just stopped working for no obvious reason. It is no longer shown in Device Manager or Adapter Settings, driver cannot be reinstalled (QMI module does not exist, whatever that means), reinstalling Windows 7 is not a solution either. I've been running Wamp server on it for a month or two, but to make it work I had to use DMZ mode on my TP-Link router, which opens all common ports (not that I'm dumb enough not to know how to forward my ports, it just didn't work). On the other hand I used AVG PC TuneUp's turbo mode before it happened. AVG Internet Security's Firewall has also been working for a bit long. The Diagnostics tool says I haven't plugged in the Ethernet cable or it could be damaged. I think that is all the info I currently have, if you need more - ask.

Thanks in advance.

0 Kudos
9 Replies

RE: Built-in WiFi modem suddenly stopped working

Hi, 

Can you try doing a system restore please.

How about the link led's on the port, are they lit?

Did you try a different cable (curious) ?

Regards

Hema

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
Highlighted
User_BG
1 Nickel

RE: Built-in WiFi modem suddenly stopped working

I think I said it, but I reinstalled Windows 7 competely after it stopped working, so a system restore would be pointless at this point. Three of the LED lights (On/Off, HDD and Battery status) work properly, but the fourth, which is the one for the WiFi, isn't working ever since I installed Windows 7 using a newer package (Service Pack 1), which is before the WiFi stopped working. As for the cable - I don't even know what an Ethernet cable is, but what I do know is, that I NEVER ever used a cable connection of any type.

P.S.: Could you explain to me what an Ethernet cable is, as well as the 1394 connection. Thanks.

0 Kudos

RE: Built-in WiFi modem suddenly stopped working

Hi, 

Ethernet is also known as LAN cable used only for internet connection. 

1394 which is also known as firewire port, is used for data services, like to connect a camcorder, mobile phones etc. Used for data transfers or data view.

Keeping in mind the wireless adapter is not seen in device manager, its a hardware issue .

Curious to know, is there an entry under Other devices in device manager?

Regards

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
User_BG
1 Nickel

RE: Built-in WiFi modem suddenly stopped working

Judging by your description, the Ethernet cable has nothing to do with my issue, which has...somehow...been resolved. I turned on my laptop a couple of days ago and guess what? Just as my desktop showed up, the software driver installation window showed, saying its installing a driver for "Network Adapter", which turned out to be my Atheros built-in WiFi adapter.

As for the Device Manager - there's always one device after I reinstall my laptop. "Base system device". Windows itself is always unable to find a driver, but I have two large folders with hundreds, if not thousands of different drivers, where it does find a driver for it when I use manual driver search - Ricoh SD/MMC Card Host Controller. But I'm confused as to where exactly it is located, because I have an SD card controller, which is already installed as a different device and using a different driver, which Windows automatically installs. I want to note, that ever since I bought this laptop, I have NEVER EVER physically modified it in ANY way. I have only sent it once or twice to a local PC shop and service for cleaning the vents and fans.

0 Kudos
User_BG
1 Nickel

RE: Built-in WiFi modem suddenly stopped working

Update: Just a few minutes after I wrote my previous message last night, my screen flickered, as if the Intel Family Graphics Chipset completely shut down itself, and then turned back on. As a result, my WiFi adapter stopped working until I restarted my laptop. The other thing, that also happened, is that Windows 7's Aero effects got completely disabled. Just like if I run an older application or game that doesn't support them.

Also, when I turned on my laptop today, my WiFi adapter didn't start either until I restarted the laptop. Since the driver is installed, it might be helpful to check the Device Manager next time it stops.

0 Kudos

RE: Built-in WiFi modem suddenly stopped working

Hi, do let us know how it goes or if you happen to observe any other issues.
If the issues still crops us,then we will look for further course of action. Do PM us the system tag# at your convenience.

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
User_BG
1 Nickel

RE: Built-in WiFi modem suddenly stopped working

My service tag is <ADMIN NOTE: Service tag removed per privacy policy>. I couldn't send you a PM, so I'm posting it here.

0 Kudos

RE: Built-in WiFi modem suddenly stopped working

Hi, 

The tag is deleted due to security issues.

I have sent you a PM, please reply to the same.

Regards

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
User_BG96
1 Copper

RE: Built-in WiFi modem suddenly stopped working

Hi,

It's User_BG. The problem still occurs. My modem didn't started when I turned on my laptop a few minutes ago. I checked Device Manager before restarting it - the adapter had just vanished, as if I never had one. Even when I initiated a manual hardware changes scan the laptop coudn't detect it. "Other Devices" wasn't present (and still isn't), obviously because there are no entries inside it.

P.S.: I'll send you my service tag shortly. I had a problem with the site, but it's off-topic.

0 Kudos