Highlighted
Not applicable

Can you disable touch screen?

My touch screen is broken and when is on it clicks by it self in 6 to 10 times all over the screen constantly!!  

i tried to disable it in Device Manager didn't work also tired remove drivers and deleted it all!!
But erver single time i restart my pc i starts a windows uppdate and turn it on agen.....

0 Kudos
6 Replies
Highlighted
10 Diamond

RE: Can you disable touch screen?

Locate the driver in the device manager, right-click and select Disable.  Then apply.

0 Kudos
Highlighted
Not applicable

RE: Can you disable touch screen?

I have done that still active after a restart. is a pain, thx tho 🙂

0 Kudos
Highlighted
5 Iridium

RE: Can you disable touch screen?

" 'My touch screen is broken and when is on it clicks by it self in 6 to 10 times all over the screen constantly "

emoticon.BigSmile.title

What troubleshooting steps you tried to fix the touch screen? You check for any touch screen firmware on your Dell Product Support page ? You calibrate the touch screen to see if it will make a difference?

How Do I Calibrate My Touchscreen on my Dell System? | Dell US

How about cleaning the touch screen:

Troubleshooting Touchscreen Issues in Microsoft Windows ...

0 Kudos
Highlighted
7 Gold

RE: Can you disable touch screen?

Have you checked your BIOS setup, accessed by pressing F2 while the system is booting?  I have an option to disable it on my Latitude 7480.

0 Kudos
Highlighted
7 Gold

RE: Can you disable touch screen?

Not quite as good as disabling it in the BIOS because it will still be active and consuming battery life, but I guess if this works and the system in question doesn't have BIOS-level control of the touchscreen, this is better than nothing.

0 Kudos
Highlighted
Not applicable

RE: Can you disable touch screen?

I know that my touchscreen is a deflected product that is part of a shipment that got damaged, but my school was so stupid that they fix it whit put in a new screen form the same shipment. (I think they come to the conclusen that somting that works for a while is cheper) it works for some time but now when i left my school it started having the same problems agen so i just have to disable it I'll give it a try true bios Settings, thx tho 🙂

0 Kudos