Laptops General - Read Only

Last reply by 10-19-2017 Unsolved
Start a Discussion
2 Bronze
2 Bronze

DELL Latitude 3340 Stuck at DELL LOGO

Hello ! I need help for my Dell Laptop. When I want to use the laptop the laptop doesn't boot and stuck at the DELL LOGO. I have done several attempt to fix this 1.Enter BIOS by pressing F2. But the screen only showed me "Preparing to Enter Setup" 2.Enter Boot Menu to run Dell Diagnostics by pressing F12. But the screen onlu showed me "Preparing for one time boot menu" 3.Press FN key to enter Dell ePSA, but the screen obly showed me "Diagnostic boot selected" Please someone help me, because I need this laptop for my work. Thanks

Replies (3)
Community Manager

Hi james.hilham, 

I would like to look into this further, can you Private Message me your Service Tag on the system? Also, it sounds like you might have seen the Diagnostic Boot Screen, but can you try these steps below to see if it gets any further:

1. Disconnect the AC adapter from the system and remove the system battery.
2. Hold down the Power button for approximately 10 seconds to drain any residual power and then release the power button
3. Hold the power button down once more while inserting the AC adapter into the system. This will initiate the Forced ePSA which may clear the state causing the system to remain at the Dell splash screen.
4. Release the power button once you see any text on the display or the Dell splash screen\
5. The Dell ePSA (Pre-boot System Assessment) diagnostic page will next appear
6. If the ePSA page does not appear then the recovery method was not effective.
7. Should ePSA initiate allow it to complete the quick test to determine if any component failures exist.
8. Should the system recover from the condition and boot into the operating system, it is very important to update the system BIOS immediately after the system has recovered to prevent a reoccurrence.

You also view a video on the steps here: 

Lastly, when the system freezes at the Dell startup screen, can you let me know if there are any diagnostic LEDs, such as a certain blinking light pattern (there might even be solid lights) for the HDD LED, Power LED, and/or the Wireless LED? This might give us an indication of what is wrong with the system.

Best regards,


If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

2 Bronze
2 Bronze

Hi Brad,

I have followed your instructions and they unfortunately do not work.

When taking out the battery and draining the power then while holding down the power button and inserting the AC power adapter it does attempt to boot to the diagnostic boot menu as you can see this in the top right hand corner but I have left it for over 30 minutes and it just stays on the dell splash screen.

Regarding the LED lights there is only a solid white light on the battery and power LEDs.

I have also private messaged you the service tag.

Many thanks,


3 Silver

I tried Brad's suggestions on a Latitude 3340 and got one pc to work but I can't get a 2nd Latitude 3340 to boot up past the splash screen.  I tried taking out the stick of memory and got the Diagnostic Selected option but nothing happens.  

Latest Solutions
Top Contributor