emeak
1 Nickel

DELL VOSTRO 3700 clean install WIN 7 need drivers

Hi,

looking for a bit of help. I just clean installed WIN 7 PRO on an old Vostro 3700. Now I'm looking to load drivers. Don't have network connection no driver. I can get driver off DELL easy enough but how do I find which ones to use and in what order to load??
Does DELl have a standalone tool to scan my machine and tell me which drivers I need?

Thanks in advance

0 Kudos
4 Replies
9 Rhodium

RE: DELL VOSTRO 3700 clean install WIN 7 need drivers

You'll need to chipset driver and the driver for whatever you use to connect to the Internet (wired or wireless Ethernet).

If wireiess, identify the card before downloading the driver (use the service tag at support.dell.com or open the cover and visually check the card).  DO NOT guess which card you have - make sure you load only the correct driver.

Put those on a flash drive, install the chipset driver and Ethernet drivers - then go online and fully update Windows 7 with SP1 (this is likely at least a day's worth of work, or use the "SP2" rollup for 7) and download the other drivers.

0 Kudos
emeak
1 Nickel

RE: DELL VOSTRO 3700 clean install WIN 7 need drivers

Hi Thanks for the advice.

Looked up my machine using service tag and then used the list of drivers

The wireless drive I'm trying to download from dell is faulty. It doesn't extract properly.

Filename: R270598.exe

Dell Wireless WLAN 1501 Half Mini-Card (4313bgn), v.5.60.48.35, A00

Who do I notify? DO I let DELL support know.

0 Kudos
9 Rhodium

RE: DELL VOSTRO 3700 clean install WIN 7 need drivers

The file:

www.dell.com/.../DriversDetails

downloads and extracts just fine.  Try another system or a different browser.

0 Kudos
emeak
1 Nickel

RE: DELL VOSTRO 3700 clean install WIN 7 need drivers

 So I managed to get the correct wireless driver and have an internet connect. Thought my probs were over. I run the DELL DETECT software tools to detect the drivers I need and it gives me an error (see attached screen shot). How annoying. I've tried twice now. How do I fix this.......

0 Kudos