Highlighted
Not applicable

Dell 7559 4k mouse lag after Windows 10 latest update

Jump to solution

Hi, I just bought the dell 7559 4k laptop, it works great but right after updating the laptop with latest windows 10 update, there is a weird mouse lag on the desktop screen. The lag only seems to appear on the desktop, or if the mouse if hover over the taskbar at the bottom. The lag is really annoying and its hard to describe, like the mouse cursor just move very very slowly, sometime you will do the action (moue your finger on the touchpad) but the mouse wont move, and then suddenly it will move. If someone else is having this issue with the Dell 7559 4k series please let me know if there is a solution. I have alredy updated the BIOS, updated all intel driver and the nvidia drivers.

1 Solution

Accepted Solutions
Highlighted
Not applicable

RE: Dell 7559 4k mouse lag after Windows 10 latest update

Jump to solution

I had the same issue- the touchpad was unusable for me the lag was so bad.

Here's how I fixed it:

Open GeForce Experience app and under general settings -look for the gear icon top right-turn off the 'Share' option.

Got this solution here -credit where credit is due:

answers.microsoft.com/.../638c43ac-1bbe-4862-984e-6d9a9a23a5b1

View solution in original post

2 Replies
Highlighted
Not applicable

RE: Dell 7559 4k mouse lag after Windows 10 latest update

Jump to solution

I had the same issue- the touchpad was unusable for me the lag was so bad.

Here's how I fixed it:

Open GeForce Experience app and under general settings -look for the gear icon top right-turn off the 'Share' option.

Got this solution here -credit where credit is due:

answers.microsoft.com/.../638c43ac-1bbe-4862-984e-6d9a9a23a5b1

View solution in original post

Highlighted
Not applicable

RE: Dell 7559 4k mouse lag after Windows 10 latest update

Jump to solution

"This was caused by the screen recording overlay in NVIDIA GeForce Experience 3. To fix it open GeForce Experience, click the gear (upper right) to go to the settings menu, and under General turn off the Share option."