Highlighted
shsiddha
1 Copper

Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

Hi,

I have a new Dell 7567, i5, 8GB, GTX1050.

Problem is it runs smoothly on battery but as soon as plugged it, I see FPS drop till battery reached about full.

I've checked and re-checked all my windows/software settings. They're same for both modes (Power and Battery).

I'm honestly clueless what's happening.

All my drivers are up to date. Windows is up to date.

Any help would be appreciated.

Regards,

Shantanu

0 Kudos
6 Replies
LSUFAN51
4 Ruthenium

RE: Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

emoticon.BigSmile.title

Please verify the System Setup(BIOS) version on the system. Type msinfo32 onto [Cortana] search box, and then stroll down to BIOS Version / Date. You should see it.

0 Kudos
LSUFAN51
4 Ruthenium

RE: Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

In the meantime, you could check and change the power plan in Power Options.  Please type Settings onto [Cortana] search box,  click System, Power & Sleep, Additional Power Settings and select Create A Power Plan.

0 Kudos
shsiddha
1 Copper

RE: Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

hi LSUFAN51,

MY BIOS version is: BIOS Version/Date: Dell Inc. 1.4.0, 11-12-2017.

And the power plan settings I have tried. I tried editing the balanced power plan. Made sure all settings are same for battery and power. I still had 0 difference.

Also, I ran the Dell diagnostics (Stress Tests and Full Diagnostics). All tests came out ok. Hence, hardware is fine.

Regards,

Shantanu

0 Kudos
LSUFAN51
4 Ruthenium

RE: Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

Type Device manager onto the search box, stroll down to Display Adapters(Video) and expand it. Right click NVIDIA driver, and select Update Driver. After, right click driver again, select Properties, Driver and then check Driver version. Please verify the latest version were correctly installed in the link below.

www.dell.com/.../driversdetails

Also do the same for the Intel  HD Graphic driver:

www.dell.com/.../driversdetails  

0 Kudos
LSUFAN51
4 Ruthenium

RE: Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

If latest Video drivers were correctly installed:

I suggest you check out the information in link below, hopefully it would be helpful to you.

How to increase FPS in Windows 10, 8.1 or 7

Since this is a brand new computer, I would suggest contacting Dell Technical Support for further assistance in link below. Keep in mind, you have 30 days (Invoice Date) of software support.

Contact Information | Dell US

0 Kudos
shsiddha
1 Copper

RE: Dell 7567 lags/FPS drop while plugged in but runs perfect on battery

hi,

Thanks again for the revert. However all the drivers etc. are latest. I keep my PC up to date.

The performance was fine since the purchase. It has deteriorated suddenly off late.

Regards,

Shantanu

0 Kudos