1 Nickel

Dell 7720 SE Corrupt Bios


I have a Dell laptop 7720 which has worked well for years. However, last week i tried to turn it on and it got to the Dell bios and stopped. So after a few minutes, i removed the power, waited, plugged it back in again and tried again.

Now it boots to a black screen. There is no spinup from HDD or CDROM, no fans either, no beeps either.

I can make it beep if i remove the memory sticks, and I can press D when it starts and the screen goes though its check but then ends and just sits there

So, my thinking is i have a corrupt bios. Okay easy enough to fix...... or so I thought.

I have downloaded the recent 7720A16.exe file, extracted the BIOS.rom from this.

I have then put it onto a 2 GB stick which i have tried formatting as FAT and FAT32.

I then do the usual remove battery, remove power. Stick in USB port (I have tried all 4 of them) and whilst holding down the END key, plug it back in again. The USB is read and then stops and i am stil left with a blank screen and nothing happens, despite this method being posted in many places for fixing a corrupt bios. I have tried also including dosflash with it, and the phonexic crysis USB disk (although this asks for BIOS.WPH not a *.CAP one)

So, what do i do please? What am i doing wrong?

I am normally very geeky and have fixed many other peoples pcs and tablets so i cant see what i am doing wrong here.

Many thanks


Tags (1)
0 Kudos