Highlighted
revolver1990
1 Copper

Dell 7720 se driver problem(charger not detected, driver failure) windows 8.1

Hello,everything started 3 weeks ago when i downloaded intel drivers for the intel hd 4000 graphics card.After i installed the drivers i rebooted  got a BSOD and bios gave me a warning that it can't recognize the charger and gave me 3 options(f1,f2,f3)i pressed f3 in order to avoid this warning in the future.When i entered the Windows i saw that the battery was not charging but the laptop was working ok so i left it as it was.Moreover i had some issues with the sound .The next day i installed the new nvidia drivers for nvidia 650m gt and also got a BSOD.I unistalled the driver with driver sweeper in safe mode and used Malwarebytes to delete some pup files .Afterwards nvidia graphics card was detected and i managed to install the dell drivers.Everything was working fine except the thing with the charger .

So i decided to unistall some intel drivers(very stupid of me).I unistalled intel(R) 7 series/c216 chipset family usb enhanced host controller-1E2D and 1E26,Intel(R) usb 3.0 eXtensible host controller -0100(microsoft),host controller usb (xHCI),Intel(R) management engine interface and afterwards i used driver sweeper in order to delete the intel hd driver(i used the amd option).Next i installed the drivers from the dell website and rebooted.When i entered windows everything was working ok(the charger was still unrecognized) but after 40 seconds the touchpad and the keyboard were not working at all and after 3-5 minutes the laptop froze.I tried to use a restore point but there wasn't any.Also i can't refresh windows  from the boot options because i am getting an error(the type of the error is not mentioned). I rebooted in safe mode with network  and everything was fine.Also sometimes when i reboot from normal mode the laptop freezes and i have to close it from the power button.When i press the power button again it powers up to a black screen and it only starts without the charger.That problem occurred after the deletion of the intel drivers i mentioned above.Last but not least i ran the diagnostics from the boot options and everything was ok except the fact that the charger was not recognized again.

I really don't know what else to do.At the moment i backup my files in order to be sure.The laptop didn't come with a windows dvd as they were pre installed. Iam desperate as i use the laptop for several projects and time is pressing .

Also i would like to  ask about the warranty .I bought the laptop while i was in Greece but now i live in the UK.My warranty ends in 2016...it is still on now that i live in UK right?

edit:My bios version is A16

0 Kudos