twh7458
1 Copper

Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

I recently purchased a used Dell D830 Laptop on Ebay.  Cosmetically it's in great shape, but runs very slow.  I installed a new Solid State Hard drive and installed a clean copy of Windows 7 Pro 32 bit.  Laptop also has 4 Gig of ram.  The processor is the T9500 2.6ghz.  I also upgraded the bios to the latest version which is A016.en checking the bo

Without running any software other than Windows and a browser open, the CPU % usage averages between 80 - 100%.  Should not be a heat issue because it's this way even from a cold start.  Running cpu-z it's showing the processor to be running at the minimum of 1.2ghz.  When checking the bios it also shows the CPU to be running at the minimum of 1.2.

Any ideas?

Thanks for any help you all may be able to offer!

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
MicroTest
4 Tellurium

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

Regarding low CPU speed - check if the power adapter is properly recognized !

press F2 at powerup which takes you to the BIOS screen

twh7458
1 Copper

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

Thanks!  I should have known this.  The adapter I presently am using is a spare 65w.  I just ordered a new 90w.  Thanks again for the good advise.

6 Replies
Highlighted
MicroTest
4 Tellurium

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

Regarding low CPU speed - check if the power adapter is properly recognized !

press F2 at powerup which takes you to the BIOS screen

twh7458
1 Copper

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

Thanks!  I should have known this.  The adapter I presently am using is a spare 65w.  I just ordered a new 90w.  Thanks again for the good advise.

MicroTest
4 Tellurium

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

Reasons for not properly recognized power adapters could be:

> the power adapter itself : wrong wattage,faulty power brick or a not 100% (!) Dell compatible third party product.

> loose power jack on the mainboard or daughterboard

> the mainboard (integrated circuits)

> the BIOS

Was wondering why the Ebay seller gave you the laptop without the power adapter - just hope that the new one will fix the problem - otherwise contact the seller.....

0 Kudos
adapt
1 Nickel

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

The reason is your D830 only supports 800 FSB, the T9500 runs at 1066 FSB and is self limiting.

 

If you do find different reason please let me know. I tried it with a D630 and was given that answer by intel.

M4700 256 GB Crucial M4 SSD, i7-3820QM, 8 GB 1866 Ghz RAM, Quadro K2000M etc...

XPS 430 GB 250 GB Crucial SSD, Q9550s, 16 GB 1333 Ghz RAM, GeForce GTX 650

M4400s , 128 GB Crucial SSDs, T9900s, 4 and 8 GB 800 Ghz RAM, FX 1700Ms, 8 of them

0 Kudos
twh7458
1 Copper

Re: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

Thanks for reply.  Actually the solution was simple.  I had the wrong power adapter, I needed the 90w.  Once I got the correct adapter it solved the problem.

0 Kudos
Chris42Arnold
2 Bronze

RE: Dell D830 with T9500 only clocks at minimum of 1.2ghz, should run 2.6ghz. HELP!

Jump to solution

This info is incorrect.  The T9500 runs at 800 MHz FSB.  The above user mistakenly refers to a T9500 when he means T9550, which is a separate family of processor.  The T9500 is perfectly compatible without any changes to a D830.  It will not work with the older A05 BIOS, though.  Update to the latest BIOS (A17, now), and no other changes are required.

0 Kudos