Laptops General - Read Only

Last reply by 05-27-2016 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell Inspiron 17 7737 - Still getting real time clock error after replacing cmos battery

Hey everyone! Hopefully someone can help me. I've been having this problem for maybe 2 months now where my laptop would shutdown randomly and give me a real time clock error. I googled around and found that replacing the cmos battery would fix the problem. I tried it out but still i am getting this problem. Any ideas?

Thanks

Replies (3)
10 Diamond

If the system is in warranty, call Dell for replacement of the reserve battery.

If it's out of warranty, try replacing the battery yourself (it's a CR-2032 button cell).  Manual is linked below.  If that doesn't solve the problem, the clock chip has failed and the mainboard will need to be replaced.

ftp.dell.com/.../inspiron-17-7737_Owner%27s%20Manual_en-us.pdf

2 Bronze
2 Bronze

I am using the one you mentioned. Its a a brand new of batteries too. Still it continues to shut down 

2 Bronze
2 Bronze

Hi, my laptop is presenting with the very same issue. I have replaced the CMOS battery but I still get the same error and the bios does not retain the time and date. I have spoken to Dell but as my machine is out of warranty they want to charge me over £700 for a new mainboard. This is unacceptable and the mainboard should not fail in just over 2 years. I am now in the process of arranging an independent engineers report which will be sent to Dell. I believe that this is inherent issue/ weak area on the mainboard from the time of purchase.

Top Contributor
Latest Solutions