Highlighted
Nate22
1 Copper

Dell Inspiron 17R SE 7720 Keyboard not working

When I restarted my computer it boots like normal then at the windows 8 lockscreen the keyboard (and mouse) doesn't work, and I cannot get past it. The keyboard also doesn't work on bios.

What happened prior to this:

-Windows Essentials was acting up so I tried to repair it via control panel

-It said it needed a restart so I restarted

-During the boot up process there was some sort of error that caused me to have to system restore

-So I system restored and somewhere it got stuck on the bios Dell logo

-I waited an upwards of 30 minutes then shut the computer off

-I turned it on again and it went past the bios and onto the lockscreen where I have my keyboard problems

Things I have tried:

-Pressing every button on the lockscreen

-Pressing every button on the bios

-Using a USB keyboard

-Restart several times

-Took out battery and held the power button

Whats strange about this is that the orange fn keys work, like the keyboard lights. By the way I have the fn keys set to default rather than the function keys.

I am at a total loss. I have no clue as to what I should do next. My computer is unusable and I need it for my online classes. Any Ideas?

---Update---

I decided to let the battery run down until it died, then when I turned it back on with charging, it came to a screen that said "Battery remaining capacity is 10% or lower. 'Battery is low'. Strike the F1 key to continue, F2 to run the setup utility."   So I pressed F2, and oddly enough, it worked. It took me to a menu called "Phoenix SecureCore Tiano Setup" and again the keyboard works (the usb keyboard also works).

This seems like a step in the right direction, but I still have no idea what to do next.

0 Kudos
1 Reply
Nate22
1 Copper

RE: Dell Inspiron 17R SE 7720 Keyboard not working

So after all that I found out that the keyboard does in fact work on bios, I was just too slow in pressing it. So now that I can get into the bios menu, I ran a ePSA Pre-boot System Assessment and afterwards it said that all tests passed.

Now the only problem is that the keyboard and mouse don't after the bios.

0 Kudos